summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-novaclient/python-novaclient-2012.1_rc3.ebuild')
-rw-r--r--dev-python/python-novaclient/python-novaclient-2012.1_rc3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-novaclient/python-novaclient-2012.1_rc3.ebuild b/dev-python/python-novaclient/python-novaclient-2012.1_rc3.ebuild
new file mode 100644
index 0000000..c525aa6
--- /dev/null
+++ b/dev-python/python-novaclient/python-novaclient-2012.1_rc3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="This is a client for the OpenStack Nova API. There's a Python API
+(the novaclient module), and a command-line script (nova). Each implements 100%
+of the OpenStack Nova API."
+HOMEPAGE="https://launchpad.net/nova"
+SRC_URI="http://launchpad.net/nova/essex/essex-rc3/+download/${P/_*/}~rc3.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}
+ dev-python/argparse
+ dev-python/httplib2
+ dev-python/prettytable"
+
+S=${WORKDIR}/${P/_*/}
+