summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/swift/swift-1.5.0.ebuild')
-rw-r--r--sys-cluster/swift/swift-1.5.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-cluster/swift/swift-1.5.0.ebuild b/sys-cluster/swift/swift-1.5.0.ebuild
new file mode 100644
index 0000000..374639b
--- /dev/null
+++ b/sys-cluster/swift/swift-1.5.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="Swift is a highly available, distributed, eventually consistent
+object/blob store"
+HOMEPAGE="https://launchpad.net/swift"
+SRC_URI="http://launchpad.net/${PN}/folsom/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="storage-server proxy-server"
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}
+ dev-python/netifaces
+ dev-python/eventlet
+ dev-python/webob
+ dev-python/pastedeploy
+ dev-python/pyxattr"
+
+# Can only use this when python.eclass is using EAPI4
+#REQUIRED_USE="|| ( storage-server proxy-server )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-client-authv2.patch"
+}
+
+src_install()
+{
+ distutils_src_install
+
+ dodir "/var/run/swift"
+
+ if use proxy-server; then
+ newinitd "${FILESDIR}/swift-proxy-server.initd" swift-proxy-server
+ fi
+
+ if use storage-server; then
+ newinitd "${FILESDIR}/swift-storage-server.initd" swift-storage-server
+ newconfd "${FILESDIR}/swift-storage-server.confd" swift-storage-server
+ fi
+}