summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/smatch/smatch-9999.ebuild')
-rw-r--r--sys-devel/smatch/smatch-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-devel/smatch/smatch-9999.ebuild b/sys-devel/smatch/smatch-9999.ebuild
new file mode 100644
index 0000000..0e8421d
--- /dev/null
+++ b/sys-devel/smatch/smatch-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools
+inherit git
+
+DESCRIPTION="Static analysis for C"
+HOMEPAGE="http://repo.or.cz/w/smatch.git"
+EGIT_REPO_URI="git://repo.or.cz/smatch.git"
+
+KEYWORDS=""
+
+LICENSE="OSL-1.1"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!sys-devel/sparse"
+
+src_compile() {
+ sed -i \
+ -e '/^PREFIX=/s:=.*:=/usr:' \
+ -e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
+ Makefile || die
+ epatch "${FILESDIR}/${PN}-fix-compiler-warnings.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc FAQ README README-smatch
+}