summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2012-05-27 17:10:31 +0000
committerAndreas Proschofsky <suka@gentoo.org>2012-05-27 17:10:31 +0000
commitbc7a1b736356f658954780dfa14e270513d1eff7 (patch)
tree0fa6cff9bcdaad1d34a192a81e529dee24b899ff
parentdev-buil of gnome-document, plus a patch to increase search speed in the gnom... (diff)
downloadsuka-bc7a1b736356f658954780dfa14e270513d1eff7.tar.gz
suka-bc7a1b736356f658954780dfa14e270513d1eff7.tar.bz2
suka-bc7a1b736356f658954780dfa14e270513d1eff7.zip
Add actually working live ebuilds for gnome-settings-daemon / gnome-control-center 3.5 (including one new dependency)
svn path=/; revision=334
-rw-r--r--dev-libs/libpwquality/Manifest2
-rw-r--r--dev-libs/libpwquality/libpwquality-1.1.0.ebuild22
-rw-r--r--eclass/gnome2-live.eclass194
-rw-r--r--gnome-base/gnome-control-center/Manifest2
-rw-r--r--gnome-base/gnome-control-center/files/gnome-control-center-3.5.1-optional-bt-colord-goa-wacom.patch193
-rw-r--r--gnome-base/gnome-control-center/gnome-control-center-9999.ebuild137
-rw-r--r--gnome-base/gnome-settings-daemon/Manifest2
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.5.1-optional-color-wacom.patch110
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999.ebuild123
9 files changed, 785 insertions, 0 deletions
diff --git a/dev-libs/libpwquality/Manifest b/dev-libs/libpwquality/Manifest
new file mode 100644
index 0000000..625af54
--- /dev/null
+++ b/dev-libs/libpwquality/Manifest
@@ -0,0 +1,2 @@
+DIST libpwquality-1.1.0.tar.bz2 358017 RMD160 7788c9f2f4fd155981845d8ee59a66b82fa4170c SHA1 f4068d67194d8dfb3a6cb9e624069238b482d066 SHA256 1aad05fd8801165aa5c14badf06d3b8c94b2f4213016e0f09d73a3973c41db93
+EBUILD libpwquality-1.1.0.ebuild 609 RMD160 eeea609f06d7ff450d674e30cb9967c00dd478ba SHA1 09f7ae79e388e1020c98d71187f0ffeb4e84e844 SHA256 c6bf29d9fe0c9d140ba2043da6a141803b050c4684d8af79dab65b714e42be7f
diff --git a/dev-libs/libpwquality/libpwquality-1.1.0.ebuild b/dev-libs/libpwquality/libpwquality-1.1.0.ebuild
new file mode 100644
index 0000000..db88bb2
--- /dev/null
+++ b/dev-libs/libpwquality/libpwquality-1.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libwacom/libwacom-0.4.ebuild,v 1.2 2012/05/04 18:35:48 jdhore Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.7"
+
+inherit python
+
+DESCRIPTION="Library for password quality checking and generating random passwords"
+HOMEPAGE="https://fedorahosted.org/libpwquality/"
+SRC_URI="https://fedorahosted.org/releases/l/i/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/cracklib-2.8
+ virtual/pam"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
diff --git a/eclass/gnome2-live.eclass b/eclass/gnome2-live.eclass
new file mode 100644
index 0000000..897adf8
--- /dev/null
+++ b/eclass/gnome2-live.eclass
@@ -0,0 +1,194 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+#
+# @ECLASS: gnome2-live.eclass
+# @MAINTAINER:
+# gnome@gentoo.org
+# @AUTHOR:
+# Nirbheek Chauhan <nirbheek@gentoo.org>
+# @BLURB: Live ebuild phases for GNOME packages
+# @DESCRIPTION:
+# Exports additional functions used by live ebuilds written for GNOME packages
+# Always to be imported *AFTER* gnome2.eclass
+#
+
+inherit autotools gnome2 gnome2-utils libtool git-2
+
+# Stolen from git.eclass
+EXPORTED_FUNCTIONS="src_unpack pkg_postinst"
+case "${EAPI:-0}" in
+ 2|3|4) EXPORTED_FUNCTIONS="${EXPORTED_FUNCTIONS} src_prepare" ;;
+ 0|1) ;;
+ *) die "Unknown EAPI, Bug eclass maintainers." ;;
+esac
+EXPORT_FUNCTIONS ${EXPORTED_FUNCTIONS}
+
+# DEPEND on
+# app-text/gnome-doc-utils for gnome-doc-*
+# dev-util/gtk-doc for gtkdocize
+# dev-util/intltool for intltoolize
+# gnome-base/gnome-common for GNOME_COMMON_INIT
+DEPEND="${DEPEND}
+ app-text/gnome-doc-utils
+ app-text/yelp-tools
+ dev-util/gtk-doc
+ dev-util/intltool
+ gnome-base/gnome-common
+ sys-devel/gettext"
+
+# Extra options passed to elibtoolize
+ELTCONF=${ELTCONF:-}
+
+# @ECLASS-VARIABLE: GNOME_LIVE_MODULE
+# @DESCRIPTION:
+# Default git module name is assumed to be the same as the gnome.org module name
+# used on ftp.gnome.org. We have GNOME_ORG_MODULE because we inherit gnome.org
+: ${GNOME_LIVE_MODULE:="${GNOME_ORG_MODULE}"}
+
+# @ECLASS-VARIABLE: EGIT_REPO_URI
+# @DESCRIPTION:
+# git URI for the project, uses GNOME_LIVE_MODULE by default
+: "${EGIT_REPO_URI:="git://git.gnome.org/${GNOME_LIVE_MODULE}"}"
+
+# @ECLASS-VARIABLE: PATCHES
+# @DESCRIPTION:
+# Whitespace-separated list of patches to apply after cloning
+: ${PATCHES:=""}
+
+# Unset SRC_URI auto-set by gnome2.eclass
+SRC_URI=""
+
+# @FUNCTION: gnome2-live_get_var
+# @DESCRIPTION:
+# Get macro variable values from configure.ac, etc
+gnome2-live_get_var() {
+ local var f
+ var="$1"
+ f="$2"
+ echo $(sed -ne "s/${var}(\(.*\))/\1/p" "${f}" | tr -d '[]')
+}
+
+# @FUNCTION: gnome2-live_get_var
+# @DESCRIPTION:
+# Calls git-2_src_unpack, and unpacks ${A} if required.
+# Also calls gnome2-live_src_prepare for older EAPI.
+gnome2-live_src_unpack() {
+ if test -n "${A}"; then
+ unpack ${A}
+ fi
+ git-2_src_unpack
+ has src_prepare ${EXPORTED_FUNCTIONS} || gnome2-live_src_prepare
+}
+
+# @FUNCTION: gnome2-live_src_prepare
+# @DESCRIPTION:
+# Lots of magic to workaround autogen.sh quirks in various packages
+# Creates blank ChangeLog and necessary macro dirs. Runs various autotools
+# programs if required, and finally runs eautoreconf.
+gnome2-live_src_prepare() {
+ # Blame git.eclass
+ cd "${S}"
+
+ for i in ${PATCHES}; do
+ epatch "${i}"
+ done
+
+ # If ChangeLog doesn't exist, maybe it's autogenerated
+ # Avoid a `dodoc` failure by adding an empty ChangeLog
+ if ! test -e ChangeLog; then
+ echo > ChangeLog
+ fi
+
+ # Find and create macro dirs
+ local macro_dirs=($(gnome2-live_get_var AC_CONFIG_MACRO_DIR configure.*))
+ for i in "${macro_dirs[@]}"; do
+ mkdir -p "$i"
+ done
+
+ # We don't run gettextize because that does too much stuff
+ if grep -qe 'GETTEXT' configure.*; then
+ # Generate po/Makefile.in.in if it doesn't exist for packages that use
+ # AM_GNU_GETTEXT and AM_GNU_GETTEXT_VERSION (e.g. media-libs/cogl).
+ # Logic is inspired by gnome-autogen.sh
+ if ! grep -qe '^AM_GLIB_GNU_GETTEXT' configure.* &&
+ grep -qe '^AM_GNU_GETTEXT_VERSION' configure.* &&
+ [[ -d po && ! -e po/Makefile.in.in && ! -e po/Makefile.am ]]; then
+ eautopoint --force
+ fi
+ local aux_dir=${S}/$(gnome2-live_get_var AC_CONFIG_AUX_DIR configure.*)
+ mkdir -p "${aux_dir}"
+ test -e "${aux_dir}/config.rpath" || :> "${aux_dir}/config.rpath"
+ test -e "${aux_dir}/ABOUT-NLS" || cp "${ROOT}/usr/share/gettext/ABOUT-NLS" "${aux_dir}"
+ fi
+
+ if grep -qe 'GTK_DOC' configure.*; then
+ ebegin "Running gtkdocize"
+ gtkdocize
+ eend $?
+ fi
+ if grep -qe 'GNOME_DOC_INIT' configure.*; then
+ ebegin "Running gnome-doc-common"
+ gnome-doc-common
+ eend $?
+ ebegin "Running gnome-doc-prepare --automake"
+ gnome-doc-prepare --automake
+ eend $?
+ fi
+ if grep -qe "IT_PROG_INTLTOOL" -e "AC_PROG_INTLTOOL" configure.*; then
+ if grep -qe "AC_PROG_INTLTOOL" configure.*; then
+ eqawarn "This package is using deprecated AC_PROG_INTLTOOL macro."
+ eqawarn "Please fill a bug to the upstream of this package."
+ fi
+ ebegin "Running intltoolize --force"
+ intltoolize --force
+ eend $?
+ fi
+ if test -e m4; then
+ AT_M4DIR=m4 eautoreconf
+ else
+ eautoreconf
+ fi
+
+ # Disable pyc compiling. Doesn't harm if DNE
+ echo > py-compile
+ chmod +x py-compile
+
+ ### Keep this in-sync with gnome2.eclass!
+
+ # Don't use the session bus address inherited via the environment
+ # causes test and introspection-building failures
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ # Prevent scrollkeeper access violations
+ gnome2_omf_fix
+
+ # Libtool patching
+ elibtoolize ${ELTCONF}
+}
+
+# @FUNCTION: gnome2_src_unpack
+# @DESCRIPTION:
+# Defined so that it replaces gnome2_src_unpack in ebuilds that call it
+gnome2_src_unpack() {
+ gnome2-live_src_unpack
+}
+
+# @FUNCTION: gnome2_src_prepare
+# @DESCRIPTION:
+# Defined so that it replaces gnome2_src_prepare in ebuilds that call it
+gnome2_src_prepare() {
+ gnome2-live_src_prepare
+}
+
+# @FUNCTION: gnome2-live_pkg_postinst
+# @DESCRIPTION:
+# Must be run manually for ebuilds that have a custom pkg_postinst
+gnome2-live_pkg_postinst() {
+ gnome2_pkg_postinst
+
+ ewarn "This is a live ebuild, upstream trunks will mostly be UNstable"
+ ewarn "Do NOT report bugs about this package to Gentoo"
+ ewarn "Report upstream bugs (with patches if possible) instead."
+}
diff --git a/gnome-base/gnome-control-center/Manifest b/gnome-base/gnome-control-center/Manifest
new file mode 100644
index 0000000..564060f
--- /dev/null
+++ b/gnome-base/gnome-control-center/Manifest
@@ -0,0 +1,2 @@
+AUX gnome-control-center-3.5.1-optional-bt-colord-goa-wacom.patch 6674 RMD160 497c335cceacbfb3436acc3cbead9d5bbd7afb0c SHA1 41818bcb51aa237545cbff43b11d6f0e69817c0e SHA256 3a31a4ebfcde70d75691c606a3a86ed366fa114d74e60d3ff3bb4b74945660a3
+EBUILD gnome-control-center-9999.ebuild 4020 RMD160 69757ca960eed50f4edf80bcebb43df9b1931b49 SHA1 7b1eefed1ea57a106a5b53c9f14b5bd23ab1b06c SHA256 0ab8a3550d8947fe7844b35130946169c0760575c81d563e96a601c61781c474
diff --git a/gnome-base/gnome-control-center/files/gnome-control-center-3.5.1-optional-bt-colord-goa-wacom.patch b/gnome-base/gnome-control-center/files/gnome-control-center-3.5.1-optional-bt-colord-goa-wacom.patch
new file mode 100644
index 0000000..92423a9
--- /dev/null
+++ b/gnome-base/gnome-control-center/files/gnome-control-center-3.5.1-optional-bt-colord-goa-wacom.patch
@@ -0,0 +1,193 @@
+From 93d009037aa3321e2eea86ef2e70cde959c5a250 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sun, 13 May 2012 19:53:13 -0400
+Subject: [PATCH] Make bluetooth, colord, gnome-online-accounts, wacom
+ optional
+
+---
+ configure.ac | 101 ++++++++++++++++++++++++++++++++++++++++++++++------
+ panels/Makefile.am | 17 +++++++--
+ 2 files changed, 103 insertions(+), 15 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index d496365..2d2d15e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -106,10 +106,44 @@ PKG_CHECK_MODULES(MEDIA_PANEL, $COMMON_MODULES)
+ PKG_CHECK_MODULES(MOUSE_PANEL, $COMMON_MODULES xi >= 1.2
+ gnome-settings-daemon >= $GSD_REQUIRED_VERSION x11)
+ PKG_CHECK_MODULES(NETWORK_PANEL, $COMMON_MODULES)
+-PKG_CHECK_MODULES(ONLINE_ACCOUNTS_PANEL, $COMMON_MODULES goa-1.0 goa-backend-1.0)
++build_online_accounts=false
++AC_ARG_ENABLE(goa,
++ AC_HELP_STRING([--disable-goa],
++ [disable online accounts management panel]),
++ [case "${enableval}" in
++ yes) WANT_ONLINE_ACCOUNTS=yes ;;
++ no) WANT_ONLINE_ACCOUNTS=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-goa) ;;
++ esac],
++ [WANT_ONLINE_ACCOUNTS=yes]) dnl Default value
++
++if test x$WANT_ONLINE_ACCOUNTS = xyes; then
++ PKG_CHECK_MODULES(ONLINE_ACCOUNTS_PANEL, $COMMON_MODULES goa-1.0 goa-backend-1.0)
++ build_online_accounts=true
++fi
++AM_CONDITIONAL(BUILD_ONLINE_ACCOUNTS, test "x$build_online_accounts" = "xtrue")
++AC_SUBST(ONLINE_ACCOUNTS_PANEL_CFLAGS)
++AC_SUBST(ONLINE_ACCOUNTS_PANEL_LIBS)
+ PKG_CHECK_MODULES(POWER_PANEL, $COMMON_MODULES upower-glib >= 0.9.1
+ gnome-settings-daemon >= $GSD_REQUIRED_VERSION)
+-PKG_CHECK_MODULES(COLOR_PANEL, $COMMON_MODULES colord >= 0.1.8)
++build_color=false
++AC_ARG_ENABLE(color,
++ AC_HELP_STRING([--disable-color],
++ [disable color management panel]),
++ [case "${enableval}" in
++ yes) WANT_COLOR=yes ;;
++ no) WANT_COLOR=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-color) ;;
++ esac],
++ [WANT_COLOR=yes]) dnl Default value
++
++if test x$WANT_COLOR = xyes; then
++ PKG_CHECK_MODULES(COLOR_PANEL, $COMMON_MODULES colord >= 0.1.8)
++ build_color=true
++fi
++AM_CONDITIONAL(BUILD_COLOR, test "x$build_color" = "xtrue")
++AC_SUBST(COLOR_PANEL_CFLAGS)
++AC_SUBST(COLOR_PANEL_LIBS)
+ PKG_CHECK_MODULES(PRINTERS_PANEL, $COMMON_MODULES
+ polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION)
+ PKG_CHECK_MODULES(REGION_PANEL, $COMMON_MODULES libgnomekbd >= 2.91.91
+@@ -145,10 +145,24 @@
+ fi
+ AM_CONDITIONAL(BUILD_NETWORK, [test x$have_networkmanager = xyes])
+
+-# Check for gnome-bluetooth
+-PKG_CHECK_MODULES(BLUETOOTH, $COMMON_MODULES gnome-bluetooth-1.0 >= 3.3.4,
+- [have_bluetooth=yes], have_bluetooth=no)
+-AM_CONDITIONAL(BUILD_BLUETOOTH, [test x$have_bluetooth = xyes])
++build_bluetooth=false
++AC_ARG_ENABLE(bluetooth,
++ AC_HELP_STRING([--disable-bluetooth],
++ [disable bluetooth management panel]),
++ [case "${enableval}" in
++ yes) WANT_BLUETOOTH=yes ;;
++ no) WANT_BLUETOOTH=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-bluetooth) ;;
++ esac],
++ [WANT_BLUETOOTH=yes]) dnl Default value
++
++if test x$WANT_BLUETOOTH = xyes; then
++ # Check for gnome-bluetooth
++ PKG_CHECK_MODULES(BLUETOOTH, $COMMON_MODULES gnome-bluetooth-1.0 >= 3.3.4)
++ build_bluetooth=true
++fi
++
++AM_CONDITIONAL(BUILD_BLUETOOTH, [test x$build_bluetooth = xtrue])
+
+ # Check for CUPS 1.4 or newer
+ AC_ARG_ENABLE([cups],
+@@ -205,11 +205,25 @@
+ if test "$host_cpu" = s390 -o "$host_cpu" = s390x; then
+ have_wacom=no
+ else
+- PKG_CHECK_MODULES(WACOM_PANEL, $COMMON_MODULES
+- gnome-settings-daemon >= $GSD_REQUIRED_VERSION
+- xi >= 1.2 x11 libwacom >= $LIBWACOM_REQUIRED_VERSION
+- gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION)
+- have_wacom=yes
++ build_wacom=false
++ AC_ARG_ENABLE(wacom,
++ AC_HELP_STRING([--disable-wacom],
++ [disable wacom management panel]),
++ [case "${enableval}" in
++ yes) WANT_WACOM=yes ;;
++ no) WANT_WACOM=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-wacom) ;;
++ esac],
++ [WANT_WACOM=yes]) dnl Default value
++
++ if test x$WANT_WACOM = xyes; then
++ PKG_CHECK_MODULES(WACOM_PANEL, $COMMON_MODULES
++ gnome-settings-daemon >= $GSD_REQUIRED_VERSION
++ xi >= 1.2 x11 libwacom >= $LIBWACOM_REQUIRED_VERSION
++ gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION)
++ build_wacom=true
++ fi
++ AM_CONDITIONAL(BUILD_WACOM, test "x$build_wacom" = "xtrue")
+ fi
+ ;;
+ *)
+@@ -423,11 +487,16 @@ if test "x$have_networkmanager" = "xyes"; then
+ else
+ AC_MSG_NOTICE([ Network panel disabled])
+ fi
+-if test "x$have_bluetooth" = "xyes"; then
++if test "x$build_bluetooth" = "xtrue"; then
+ AC_MSG_NOTICE([** gnome-bluetooth (Bluetooth panel)])
+ else
+ AC_MSG_NOTICE([ Bluetooth panel disabled])
+ fi
++if test "x$build_color" = "xtrue"; then
++ AC_MSG_NOTICE([** colord (Color panel)])
++else
++ AC_MSG_NOTICE([ Color panel disabled])
++fi
+ if test "x$enable_cups" = "xyes"; then
+ AC_MSG_NOTICE([** CUPS (Printers panel)])
+ else
+@@ -438,6 +507,11 @@ if test "x$have_cheese" = "xyes"; then
+ else
+ AC_MSG_NOTICE([ Users panel webcam support disabled])
+ fi
++if test "x$build_online_accounts" = "xtrue"; then
++ AC_MSG_NOTICE([** gnome-online-accounts (Online Accounts panel)])
++else
++ AC_MSG_NOTICE([ Online Accounts panel disabled])
++fi
+ if test "x$with_libsocialweb" = "xyes"; then
+ AC_MSG_NOTICE([** libsocialweb (Background panel Flickr support)])
+ else
+@@ -448,4 +522,9 @@ if test "x$with_systemd" = "xyes"; then
+ else
+ AC_MSG_NOTICE([ Using ConsoleKit for session tracking])
+ fi
++if test "x$build_wacom" = "xtrue"; then
++ AC_MSG_NOTICE([** libwacom (Wacom Graphics Tablet panel)])
++else
++ AC_MSG_NOTICE([ Wacom Graphics Tablet panel disabled])
++fi
+ AC_MSG_NOTICE([End options])
+diff --git a/panels/Makefile.am b/panels/Makefile.am
+index 172dd06..134b0c8 100644
+--- a/panels/Makefile.am
++++ b/panels/Makefile.am
+@@ -3,10 +3,8 @@
+ background \
+ screen \
+ power \
+- color \
+ display \
+ mouse \
+- online-accounts \
+ region \
+ info \
+ sound \
+@@ -31,4 +29,12 @@
+ SUBDIRS += bluetooth
+ endif
+
++if BUILD_COLOR
++SUBDIRS += color
++endif
++
++if BUILD_ONLINE_ACCOUNTS
++SUBDIRS += online-accounts
++endif
++
+ -include $(top_srcdir)/git.mk
+--
+1.7.8.6
+
diff --git a/gnome-base/gnome-control-center/gnome-control-center-9999.ebuild b/gnome-base/gnome-control-center/gnome-control-center-9999.ebuild
new file mode 100644
index 0000000..6016cb5
--- /dev/null
+++ b/gnome-base/gnome-control-center/gnome-control-center-9999.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes" # gmodule is used, which uses dlopen
+
+inherit autotools eutils gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="GNOME Desktop Configuration Tool"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+IUSE="+bluetooth +cheese +colord +cups +gnome-online-accounts +networkmanager +socialweb systemd wacom"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+fi
+
+# XXX: gnome-desktop-2.91.5 is needed for upstream commit c67f7efb
+# XXX: NetworkManager-0.9 support is automagic, make hard-dep once it's released
+#
+# gnome-session-2.91.6-r1 is needed so that 10-user-dirs-update is run at login
+# Latest gsettings-desktop-schemas is neededfor commit 73f9bffb
+# gnome-settings-daemon-3.1.4 is needed for power panel (commit 4f08a325)
+# g-s-d[policykit] needed for bug #403527
+COMMON_DEPEND="
+ >=dev-libs/glib-2.31.0:2
+ >=x11-libs/gdk-pixbuf-2.23.0:2
+ >=x11-libs/gtk+-3.3.5:3
+ >=gnome-base/gsettings-desktop-schemas-3.3.0
+ >=gnome-base/gnome-desktop-3.1.91:3
+ >=gnome-base/gnome-settings-daemon-3.3.92[colord?,policykit]
+ >=gnome-base/libgnomekbd-2.91.91
+
+ app-text/iso-codes
+ dev-libs/libxml2:2
+ gnome-base/gnome-menus:3
+ gnome-base/libgtop:2
+ media-libs/fontconfig
+
+ >=media-libs/libcanberra-0.13[gtk3]
+ >=media-sound/pulseaudio-0.9.16[glib]
+ >=sys-auth/polkit-0.97
+ >=sys-power/upower-0.9.1
+ >=x11-libs/libnotify-0.7.3
+ >=dev-libs/libpwquality-1.1.0
+
+ x11-apps/xmodmap
+ x11-libs/libX11
+ x11-libs/libXxf86misc
+ >=x11-libs/libxklavier-5.1
+ >=x11-libs/libXi-1.2
+
+ bluetooth? ( >=net-wireless/gnome-bluetooth-3.3.4 )
+ cheese? (
+ media-libs/gstreamer:0.10
+ >=media-video/cheese-3.3.5 )
+ colord? ( >=x11-misc/colord-0.1.8 )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ gnome-online-accounts? ( net-libs/gnome-online-accounts )
+ networkmanager? (
+ >=gnome-extra/nm-applet-0.9.1.90
+ >=net-misc/networkmanager-0.8.997 )
+ socialweb? ( net-libs/libsocialweb )
+ systemd? ( >=sys-apps/systemd-31 )
+ wacom? ( >=dev-libs/libwacom-0.5
+ x11-libs/libXi )"
+# <gnome-color-manager-3.1.2 has file collisions with g-c-c-3.1.x
+RDEPEND="${COMMON_DEPEND}
+ app-admin/apg
+ sys-apps/accountsservice
+ x11-themes/gnome-icon-theme-symbolic
+ colord? ( >=gnome-extra/gnome-color-manager-3 )
+ cups? ( net-print/cups-pk-helper )
+ !systemd? ( sys-auth/consolekit )
+ wacom? ( gnome-base/gnome-settings-daemon[wacom] )
+
+ !<gnome-base/gdm-2.91.94
+ !<gnome-extra/gnome-color-manager-3.1.2
+ !gnome-extra/gnome-media[pulseaudio]
+ !<gnome-extra/gnome-media-2.32.0-r300
+ !<net-wireless/gnome-bluetooth-3.3.2"
+# PDEPEND to avoid circular dependency
+PDEPEND=">=gnome-base/gnome-session-2.91.6-r1"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/xproto
+ x11-proto/xf86miscproto
+ x11-proto/kbproto
+
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.40.1
+ virtual/pkgconfig
+
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.10.1
+
+ cups? ( sys-apps/sed )
+
+ gnome-base/gnome-common"
+# Needed for autoreconf
+# gnome-base/gnome-common
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-update-mimedb
+ --disable-static
+ $(use_enable bluetooth)
+ $(use_with cheese)
+ $(use_enable colord color)
+ $(use_enable cups)
+ $(use_enable gnome-online-accounts goa)
+ $(use_with socialweb libsocialweb)
+ $(use_enable systemd)
+ $(use_enable wacom)"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}
+
+src_prepare() {
+ # Make some panels optional; requires eautoreconf
+ epatch "${FILESDIR}/${PN}-3.5.1-optional-bt-colord-goa-wacom.patch"
+ [[ ${PV} != 9999 ]] && eautoreconf
+
+ gnome2_src_prepare
+
+ # panels/datetime/Makefile.am gets touched as a result of something in our
+ # src_prepare(). We need to touch timedated{c,h} to prevent them from being
+ # regenerated (bug #415901)
+ [[ -f panels/datetime/timedated.h ]] && touch panels/datetime/timedated.h
+ [[ -f panels/datetime/timedated.c ]] && touch panels/datetime/timedated.c
+}
diff --git a/gnome-base/gnome-settings-daemon/Manifest b/gnome-base/gnome-settings-daemon/Manifest
new file mode 100644
index 0000000..862e8f0
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/Manifest
@@ -0,0 +1,2 @@
+AUX gnome-settings-daemon-3.5.1-optional-color-wacom.patch 4125 RMD160 93deeffb9033393077d407ac1407320437c53260 SHA1 8ff8535509e5b4e4dac5609ccffff3c993b28a38 SHA256 8c58ff638e33a93cb10b00e0dcf1b3c4729ff1ac055f183d81956acee34a58c5
+EBUILD gnome-settings-daemon-9999.ebuild 3213 RMD160 0d86accfb337f4e5c2a03e211a41d6ad75e67d3f SHA1 30872c69749b45030b1486130d1bc70d2a443847 SHA256 185571b326e49a38a4dfc53e4d410cbc379fce0b279b9f4962457075d32b8c2f
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.5.1-optional-color-wacom.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.5.1-optional-color-wacom.patch
new file mode 100644
index 0000000..4df1193
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.5.1-optional-color-wacom.patch
@@ -0,0 +1,110 @@
+diff -Naur gnome-settings-daemon-3.3.92//configure.ac gnome-settings-daemon-3.3.92.new//configure.ac
+--- gnome-settings-daemon-3.3.92//configure.ac 2012-03-19 14:23:38.000000000 +0530
++++ gnome-settings-daemon-3.3.92.new//configure.ac 2012-03-25 11:36:35.833356226 +0530
+@@ -194,30 +194,39 @@
+ dnl - color
+ dnl ---------------------------------------------------------------------------
+
+-PKG_CHECK_MODULES(COLOR, [colord >= 0.1.9 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++AC_ARG_ENABLE([color],
++ AS_HELP_STRING([--disable-color],
++ [turn off color plugin]),
++ [with_color=$enableval],
++ [with_color=yes]) dnl Default value
++
++if test x$with_color = xyes; then
++ PKG_CHECK_MODULES(COLOR, [colord >= 0.1.9 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++ AC_DEFINE(HAVE_COLOR, 1, [Define if wacom plugin is enabled])
++fi
++AM_CONDITIONAL(WITH_COLOR, test "x$with_color" = "xyes")
++
++AC_SUBST(COLOR_CFLAGS)
++AC_SUBST(COLOR_LIBS)
+
+ dnl ---------------------------------------------------------------------------
+ dnl - wacom (disabled for s390/s390x and non Linux platforms)
+ dnl ---------------------------------------------------------------------------
+
+-case $host_os in
+- linux*)
+- if test "$host_cpu" = s390 -o "$host_cpu" = s390x; then
+- have_wacom=no
+- else
+- if test x$enable_gudev != xno; then
+- PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst gudev-1.0 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION xorg-wacom])
+- else
+- AC_MSG_ERROR([GUdev is necessary to compile Wacom support])
+- fi
+- have_wacom=yes
+- fi
+- ;;
+- *)
+- have_wacom=no
+- ;;
+-esac
+-AM_CONDITIONAL(HAVE_WACOM, test x$have_wacom = xyes)
++AC_ARG_ENABLE([wacom],
++ AS_HELP_STRING([--disable-wacom],
++ [turn off wacom plugin]),
++ [have_wacom=$enableval],
++ [have_wacom=no]) dnl Default value
++
++if test x$with_wacom = xyes; then
++ PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst $GUDEV_PKG gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION xorg-wacom])
++ AC_DEFINE(HAVE_WACOM, 1, [Define if wacom plugin is enabled])
++fi
++AM_CONDITIONAL(HAVE_WACOM, test "x$with_wacom" = "xyes")
++
++AC_SUBST(WACOM_CFLAGS)
++AC_SUBST(WACOM_LIBS)
+
+ dnl ==============================================
+ dnl PackageKit section
+diff -Naur gnome-settings-daemon-3.3.92//data/Makefile.am gnome-settings-daemon-3.3.92.new//data/Makefile.am
+--- gnome-settings-daemon-3.3.92//data/Makefile.am 2012-03-16 22:59:35.000000000 +0530
++++ gnome-settings-daemon-3.3.92.new//data/Makefile.am 2012-03-25 11:39:24.548364338 +0530
+@@ -11,7 +11,6 @@
+ org.gnome.settings-daemon.plugins.gschema.xml \
+ org.gnome.settings-daemon.plugins.keyboard.gschema.xml \
+ org.gnome.settings-daemon.plugins.power.gschema.xml \
+- org.gnome.settings-daemon.plugins.color.gschema.xml \
+ org.gnome.settings-daemon.plugins.media-keys.gschema.xml \
+ org.gnome.settings-daemon.plugins.xsettings.gschema.xml \
+ org.gnome.settings-daemon.plugins.housekeeping.gschema.xml \
+@@ -30,6 +29,12 @@
+ gsettings_SCHEMAS += org.gnome.settings-daemon.plugins.orientation.gschema.xml
+ else
+ all_schemas += org.gnome.settings-daemon.plugins.orientation.gschema.xml
++endif
++
++if WITH_COLOR
++gsettings_SCHEMAS += org.gnome.settings-daemon.plugins.color.gschema.xml
++else
++all_schemas += org.gnome.settings-daemon.plugins.color.gschema.xml
+ endif
+
+ if HAVE_WACOM
+diff -Naur gnome-settings-daemon-3.3.92//plugins/Makefile.am gnome-settings-daemon-3.3.92.new//plugins/Makefile.am
+--- gnome-settings-daemon-3.3.92//plugins/Makefile.am 2012-03-16 22:59:35.000000000 +0530
++++ gnome-settings-daemon-3.3.92.new//plugins/Makefile.am 2012-03-25 11:37:47.296359651 +0530
+@@ -6,7 +6,6 @@
+ automount \
+ background \
+ clipboard \
+- color \
+ cursor \
+ dummy \
+ power \
+@@ -39,6 +38,12 @@
+ disabled_plugins += orientation
+ endif
+
++if WITH_COLOR
++enabled_plugins += color
++else
++disabled_plugins += color
++endif
++
+ if HAVE_WACOM
+ enabled_plugins += wacom
+ else
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999.ebuild
new file mode 100644
index 0000000..aa2d22b
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.2.2-r1.ebuild,v 1.2 2012/01/12 03:32:00 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 virtualx
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Gnome Settings Daemon"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+fi
+IUSE="+colord +cups debug packagekit policykit smartcard systemd +udev wacom"
+
+# colord-0.1.13 needed to avoid polkit errors in CreateProfile and CreateDevice
+COMMON_DEPEND="
+ >=dev-libs/glib-2.31.0:2
+ >=x11-libs/gtk+-3.3.4:3
+ >=gnome-base/libgnomekbd-2.91.1
+ >=gnome-base/gnome-desktop-3.3.92:3
+ >=gnome-base/gsettings-desktop-schemas-3.3.0
+ media-fonts/cantarell
+ media-libs/fontconfig
+ >=media-libs/lcms-2.2:2
+ media-libs/libcanberra[gtk3]
+ >=media-sound/pulseaudio-0.9.16
+ >=sys-power/upower-0.9.11
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/libnotify-0.7.3
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXtst
+ x11-libs/libXxf86misc
+ >=x11-libs/libxklavier-5.0
+ >=media-sound/pulseaudio-0.9.16
+
+ colord? ( >=x11-misc/colord-0.1.13 )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ packagekit? (
+ sys-fs/udev[gudev]
+ >=app-admin/packagekit-base-0.6.12 )
+ smartcard? (
+ sys-fs/udev[gudev]
+ >=dev-libs/nss-3.11.2 )
+ systemd? ( >=sys-apps/systemd-31 )
+ udev? ( sys-fs/udev[gudev] )
+ wacom? ( >=dev-libs/libwacom-0.3
+ x11-drivers/xf86-input-wacom )"
+# Themes needed by g-s-d, gnome-shell, gtk+:3 apps to work properly
+# <gnome-color-manager-3.1.1 has file collisions with g-s-d-3.1.x
+# <gnome-power-manager-3.1.3 has file collisions with g-s-d-3.1.x
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/dconf
+ >=x11-themes/gnome-themes-standard-2.91
+ >=x11-themes/gnome-icon-theme-2.91
+ >=x11-themes/gnome-icon-theme-symbolic-2.91
+ !<gnome-base/gnome-control-center-2.22
+ !<gnome-extra/gnome-color-manager-3.1.1
+ !<gnome-extra/gnome-power-manager-3.1.3
+
+ !systemd? ( sys-auth/consolekit )"
+# xproto-7.0.15 needed for power plugin
+DEPEND="${COMMON_DEPEND}
+ cups? ( sys-apps/sed )
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/xf86miscproto
+ >=x11-proto/xproto-7.0.15"
+
+pkg_setup() {
+ # README is empty
+ DOCS="AUTHORS NEWS ChangeLog MAINTAINERS"
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-schemas-compile
+ $(use_enable colord color)
+ $(use_enable cups)
+ $(use_enable debug)
+ $(use_enable debug more-warnings)
+ $(use_enable packagekit)
+ $(use_enable smartcard smartcard-support)
+ $(use_enable systemd)
+ $(use_enable udev gudev)
+ $(use_enable wacom)"
+}
+
+src_prepare() {
+
+ # Make colord and wacom optional; requires eautoreconf
+ epatch "${FILESDIR}/${PN}-3.5.1-optional-color-wacom.patch"
+
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51gsettings-dconf
+ doenvd 51gsettings-dconf
+}