summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2009-10-07 11:04:15 +0000
committerAndreas Proschofsky <suka@gentoo.org>2009-10-07 11:04:15 +0000
commitf413e8215e9ccaa5532b75da2624771328b5acd1 (patch)
treebdb432e6a706a785642c86ae5e0063339735771b /dev-libs
parentDependency on clutter-imcontext is gone again (diff)
downloadsuka-f413e8215e9ccaa5532b75da2624771328b5acd1.tar.gz
suka-f413e8215e9ccaa5532b75da2624771328b5acd1.tar.bz2
suka-f413e8215e9ccaa5532b75da2624771328b5acd1.zip
Add Emerillon, new GNOME map viewer and the necessary dependencies, for
more infos see: http://blog.pierlux.com/2009/10/06/announcing-emerillon-the-map-viewer/en/ svn path=/; revision=168
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ethos/Manifest1
-rw-r--r--dev-libs/ethos/ethos-9999.ebuild46
-rw-r--r--dev-libs/librest/Manifest2
-rw-r--r--dev-libs/librest/librest-0.6.0.ebuild34
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-libs/ethos/Manifest b/dev-libs/ethos/Manifest
new file mode 100644
index 0000000..5534b68
--- /dev/null
+++ b/dev-libs/ethos/Manifest
@@ -0,0 +1 @@
+EBUILD ethos-9999.ebuild 938 RMD160 b676156c6a50c3576a5b28c7615b10fbf0d302c5 SHA1 2dac4790bc138289c75752b239d56d7deb44bba8 SHA256 797526443d4e9bb52601efc110feb7366920c8b6b8bd530e3c6d0b7e07abb8ed
diff --git a/dev-libs/ethos/ethos-9999.ebuild b/dev-libs/ethos/ethos-9999.ebuild
new file mode 100644
index 0000000..5ae3c93
--- /dev/null
+++ b/dev-libs/ethos/ethos-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools gnome2 git
+
+EGIT_REPO_URI="git://git.dronelabs.com/ethos"
+
+DESCRIPTION="Generic Plugin Engine for GLib"
+HOMEPAGE="http://git.dronelabs.com/ethos/about/"
+SRC_URI=""
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="introspection javascript python"
+
+RDEPEND=">=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.10.0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3 )
+ javascript? ( >=dev-libs/gjs-0.2 )
+ python? ( >=dev-python/pygobject-2.15.3
+ >=dev-python/pygtk-2.12 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS NEWS README TODO"
+
+S=${WORKDIR}/trunk
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-vala
+ $(use_enable python)
+ $(use_enable javascript js)
+ $(use_enable introspection)"
+}
+
+src_unpack() {
+ git_src_unpack
+ cd ${S}
+ ./autogen.sh
+}
diff --git a/dev-libs/librest/Manifest b/dev-libs/librest/Manifest
new file mode 100644
index 0000000..da383de
--- /dev/null
+++ b/dev-libs/librest/Manifest
@@ -0,0 +1,2 @@
+DIST rest-0.6.tar.gz 379628 RMD160 8b7b5bcfd20c66ecf1551bda7785276a27746566 SHA1 9ed2814ae123b73d15598ebd0b1457ab9b6208be SHA256 8734c43d99651c17ce0346ddaac97122b92e28e21e625200b4a12a30f0d8e7f6
+EBUILD librest-0.6.0.ebuild 671 RMD160 4bde4c6f385807833c58d4b8683d467d6a7d0e2a SHA1 f2466799393ca51595299db8e86a501404bb44eb SHA256 9ffdf5d1b8c856bae99e21b366a7145acc1365cdf81626a0e0e35e70b294fa5e
diff --git a/dev-libs/librest/librest-0.6.0.ebuild b/dev-libs/librest/librest-0.6.0.ebuild
new file mode 100644
index 0000000..cabe04d
--- /dev/null
+++ b/dev-libs/librest/librest-0.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit gnome2
+
+DESCRIPTION="Library to access RESTful web-services"
+HOMEPAGE="http://moblin.org/projects/librest"
+SRC_URI="http://moblin.org/sites/all/files/rest-0.6.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome"
+
+RDEPEND=">=dev-libs/glib-2.18.0
+ >=net-libs/libsoup-2.4
+ gnome? ( >=net-libs/libsoup-gnome-2.25.1 )
+ >=dev-libs/libxml2-2"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS NEWS README"
+
+S="${WORKDIR}/rest-0.6"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with gnome)"
+}