summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/clutter/Manifest3
-rw-r--r--media-libs/clutter/clutter-1.2.0.ebuild89
-rw-r--r--media-libs/clutter/files/clutter-1.2.0-disable-tests.patch50
-rw-r--r--profiles/package.mask3
4 files changed, 145 insertions, 0 deletions
diff --git a/media-libs/clutter/Manifest b/media-libs/clutter/Manifest
index c7c9874..6f06889 100644
--- a/media-libs/clutter/Manifest
+++ b/media-libs/clutter/Manifest
@@ -1,4 +1,7 @@
AUX clutter-1.0.0-disable-tests.patch 1445 RMD160 95018f8fce1d4c2d47ebd16402a02f2c86e0fdbc SHA1 f355cb8f13cb8fd4e192c925ea23efb8ac64f40b SHA256 5e168f0854c0883fc96ae489947b5b4e3b3f5ca36b6b0b461b5acfcd36e0c815
+AUX clutter-1.2.0-disable-tests.patch 1306 RMD160 a3746ea61ceaed34ba449541bd4b5be1a2336502 SHA1 54ad9f8e2d52387ddd00ed9633a855c7e828ceac SHA256 d0d1843e2c066ac0339eb6fa68b7aa116ed7a0a4018bb7dc85ee045024abc320
DIST clutter-1.0.10.tar.bz2 2052074 RMD160 7738b2603298a687bfa056f458e84080bc880d1e SHA1 189684f0346bb895a2b47da64c02260c67e2810e SHA256 6fb98dc4d16a3a98be734cf0a6cc4f8d8179800603c3e41011c414eeaf1f456b
+DIST clutter-1.2.0.tar.bz2 2618470 RMD160 148bc0a630c82ca6280ef664889c48f86b9b884a SHA1 c4a8d8dc3aa26c65e48c76647c6776968ca56748 SHA256 009058e3b0985d34b94527440ad0f4444dba66c1c5f2ca036fa2b846fd32c3c8
EBUILD clutter-1.0.10.ebuild 2147 RMD160 e7d0c7c9029bcf043ccb05eb4bb4bdcce05b4dd0 SHA1 ffc6fd08bdfa27175f28acbb3901726721962c71 SHA256 d7843c9b4714bc0dd9c24fa0e108ea2c45d2d6ba956d70c5eefcabf92d1e62b2
+EBUILD clutter-1.2.0.ebuild 2147 RMD160 32355ef2d15e04a386a9f1e461da798f7f890329 SHA1 f4df1fa0ef2edccaaf8568bc08b62731afae2caa SHA256 5f9bc8d6fff91e8d06783fe11dced16787b3cb9d06d7b5b97224917b2b05d86d
MISC metadata.xml 602 RMD160 fa6d7f9c710892075862023297970fc261c1394c SHA1 28e1b953378601a1b93231f64a82e47a384852ce SHA256 8c76b22622c2c0793629693cfa507367f65221a1bce7b5d65c13605353718efb
diff --git a/media-libs/clutter/clutter-1.2.0.ebuild b/media-libs/clutter/clutter-1.2.0.ebuild
new file mode 100644
index 0000000..040c9c0
--- /dev/null
+++ b/media-libs/clutter/clutter-1.2.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools clutter
+
+DESCRIPTION="Clutter is a library for creating graphical user interfaces"
+
+SLOT="1.0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc +gtk introspection +opengl"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=x11-libs/cairo-1.4
+ >=x11-libs/pango-1.20
+
+ gtk? ( >=x11-libs/gtk+-2.0 )
+ opengl? (
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXdamage
+ x11-libs/libXi
+ x11-proto/inputproto
+
+ >=x11-libs/libXfixes-3
+ >=x11-libs/libXcomposite-0.4 )
+ !opengl? ( media-libs/libsdl )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/gtk-doc-am
+ doc? (
+ >=dev-util/gtk-doc-1.11
+ >=app-text/docbook-sgml-utils-0.6.14[jadetex]
+ app-text/xmlto )
+ introspection? (
+ >=dev-libs/gobject-introspection-0.6.4
+ || ( >=x11-libs/pango-1.27.1[introspection] >=dev-libs/gir-repository-0.6.3[pango] ) )"
+
+src_configure() {
+ local myconf=""
+
+ if use opengl; then
+ elog "Using GLX for OpenGL backend"
+ myconf="${myconf} --with-flavour=glx"
+ else
+ elog "Using SDL for OpenGL backend"
+ myconf="${myconf} --with-flavour=sdl"
+ ewarn "You have disabled OpenGL, do not report bugs about breakage"
+ fi
+
+ if use gtk; then
+ myconf="${myconf} --with-imagebackend=gdk-pixbuf"
+ else
+ myconf="${myconf} --with-imagebackend=internal"
+ # Internal image backend is experimental
+ ewarn "You have selected the experimental internal image backend"
+ fi
+
+ if ! use debug; then
+ myconf="${myconf}
+ --enable-debug=minimum
+ --enable-cogl-debug=minimum"
+ fi
+
+ # FIXME: Tests are interactive, not of use for us
+ # FIXME: Using external json-glib breaks introspection
+ myconf="${myconf}
+ --disable-tests
+ --enable-maintainer-flags=no
+ --enable-xinput
+ --with-json=internal
+ $(use_enable introspection)
+ $(use_enable doc manual)"
+ econf ${myconf}
+}
+
+src_prepare() {
+ # Make it libtool-1 compatible
+ rm -v build/autotools/lt* build/autotools/libtool.m4 || die "removing libtool macros failed"
+
+ # FIXME: Tests are interactive, not of use for us
+ epatch "${FILESDIR}/${PN}-1.2.0-disable-tests.patch"
+
+ eautoreconf
+}
diff --git a/media-libs/clutter/files/clutter-1.2.0-disable-tests.patch b/media-libs/clutter/files/clutter-1.2.0-disable-tests.patch
new file mode 100644
index 0000000..55b98fe
--- /dev/null
+++ b/media-libs/clutter/files/clutter-1.2.0-disable-tests.patch
@@ -0,0 +1,50 @@
+Interactive Tests.
+
+http://bugzilla.o-hand.com/show_bug.cgi?id=1618
+
+--
+--- configure.ac
++++ configure.ac
+@@ -718,6 +718,18 @@
+
+ AM_CONDITIONAL(ENABLE_MANUAL, [test "x$enable_manual" = "xyes"])
+
++dnl = tests ================================================================
++AC_ARG_ENABLE(tests,
++ AS_HELP_STRING([--enable-tests],[Enable building of tests and examples]),
++ [case "${enableval}" in
++ yes) ENABLE_TESTS=yes ;;
++ no) ENABLE_TESTS=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --enable-tests) ;;
++ esac],
++ [ENABLE_TESTS=no])
++
++AM_CONDITIONAL([ENABLE_TESTS], [test "x$ENABLE_TESTS" = "xyes"])
++
+ dnl === I18N ==================================================================
+
+ GETTEXT_PACKAGE="clutter-$CLUTTER_API_VERSION"
+@@ -887,6 +887,7 @@
+ echo ""
+ echo " • Extra:"
+ echo " Build introspection data: ${enable_introspection}"
++echo " Enable tests: ${enable_tests}"
+ echo " Build conformance test suite: ${enable_conformance}"
+
+ if test "x$have_json" = "xyes"; then
+--- Makefile.am
++++ Makefile.am
+@@ -2,7 +2,11 @@
+
+ NULL =
+
+-SUBDIRS = build clutter tests doc po
++SUBDIRS = build clutter doc po
++
++if ENABLE_TESTS
++SUBDIRS += tests
++endif
+
+ ACLOCAL_AMFLAGS = -I build/autotools
+
+
diff --git a/profiles/package.mask b/profiles/package.mask
index 02e1556..12d36bb 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -13,6 +13,9 @@
=gnome-base/gnome-shell-9999
=x11-wm/mutter-9999
+# Clutter 1.2 for newest gnome-shell
+>=media-libs/clutter-1.2.0
+
# Development versions with introspection support
# To be used instead of gir-repository