summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/json-glib/json-glib-0.12.0.ebuild')
-rw-r--r--dev-libs/json-glib/json-glib-0.12.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/json-glib/json-glib-0.12.0.ebuild b/dev-libs/json-glib/json-glib-0.12.0.ebuild
new file mode 100644
index 0000000..549438e
--- /dev/null
+++ b/dev-libs/json-glib/json-glib-0.12.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/json-glib/json-glib-0.8.2.ebuild,v 1.1 2009/11/02 20:19:10 voyageur Exp $
+
+EAPI=2
+inherit gnome2 eutils
+
+DESCRIPTION="A library providing GLib serialization and deserialization support for the JSON format"
+HOMEPAGE="http://live.gnome.org/JsonGlib"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc introspection"
+
+RDEPEND=">=dev-libs/glib-2.15"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1.11 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+G2CONF="${G2CONF} $(use_enable introspection)"