summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/openrc/openrc-9999.ebuild')
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 02abf68..e3a70d6 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,10 +1,15 @@
-inherit flag-o-matic eutils toolchain-funcs multilib
+if [ "${PV}" = "9999" ]; then
+GIT=git
+else
+GIT=
+fi
+
+inherit eutils flag-o-matic ${GIT} multilib toolchain-funcs
DESCRIPTION="OpenRC manages the services, startup and shutdown of a host"
HOMEPAGE="http://roy.marples.name/openrc"
if [ "${PV}" = "9999" ]; then
-inherit git
EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/openrc.git"
else
SRC_URI="http://roy.marples.name/${PN}/${P}.tar.bz2"
@@ -53,7 +58,7 @@ pkg_setup() {
fi
if use static && ! use pam; then
if use elibc_glibc; then
- MAKE_ARGS="${MAKE_ARG} PROGLDFLAGS=-Wl,-Bstatic"
+ MAKE_ARGS="${MAKE_ARGS} PROGLDFLAGS=-Wl,-Bstatic"
else
MAKE_ARGS="${MAKE_ARGS} PROGLDFLAGS=-static"
fi
@@ -128,8 +133,8 @@ pkg_postinst() {
"${ROOT}"etc/runlevels/boot/checkroot \
"${ROOT}"etc/runlevels/boot/rmnologin
- # Make our runlevels if they don't exist or we're a development version.
- if [ ! -e "${ROOT}"etc/runlevels -o "${PV}" = "9999" ]; then
+ # Make our runlevels if they don't exist
+ if [ ! -e "${ROOT}"etc/runlevels ]; then
einfo "Copying across default runlevels"
cp -RPp "${ROOT}"usr/share/"${PN}"/runlevels "${ROOT}"/etc
fi