summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2013-08-22 07:45:52 +0200
committerWolfram Schlich <wschlich@gentoo.org>2013-08-22 07:45:52 +0200
commit2c8d064b367a44723b9b557fb1edca59387edf49 (patch)
tree762432f58f66cfa663464bd506f40bd73a8a812d /sys-apps/memtest86+
parentinitial setup (diff)
downloadwschlich-2c8d064b367a44723b9b557fb1edca59387edf49.tar.gz
wschlich-2c8d064b367a44723b9b557fb1edca59387edf49.tar.bz2
wschlich-2c8d064b367a44723b9b557fb1edca59387edf49.zip
added all ebuilds from my old svn repository
Diffstat (limited to 'sys-apps/memtest86+')
-rw-r--r--sys-apps/memtest86+/Manifest5
-rw-r--r--sys-apps/memtest86+/files/memtest86+-1.70-gnu_hash.patch11
-rw-r--r--sys-apps/memtest86+/files/memtest86+-2.01-hardcoded_cc.patch29
-rw-r--r--sys-apps/memtest86+/files/memtest86+-2.01-serial-baud.patch12
-rw-r--r--sys-apps/memtest86+/memtest86+-2.01.ebuild70
5 files changed, 127 insertions, 0 deletions
diff --git a/sys-apps/memtest86+/Manifest b/sys-apps/memtest86+/Manifest
new file mode 100644
index 0000000..e4c1459
--- /dev/null
+++ b/sys-apps/memtest86+/Manifest
@@ -0,0 +1,5 @@
+AUX memtest86+-1.70-gnu_hash.patch 485 RMD160 355648069f4b3f6234e770bbea30dcef10405376 SHA1 dd0d673b2fdee35b1522574b1499cd943820dca5 SHA256 07bb65affa496910f0c91457c5c21e31a0e523e0c360ebf602b47296748f4bac
+AUX memtest86+-2.01-hardcoded_cc.patch 1161 RMD160 16c9dfa8770643170ae00d21c644400bb1ab0d6d SHA1 b0f9c679490eb7da40c6ef77b2944cca1f2211f3 SHA256 7d744366b7aef2a2443e8386cecb1d30e4afeca6f0b7f22b287b8edc76f98dcd
+AUX memtest86+-2.01-serial-baud.patch 455 RMD160 94542faf46d9f0a9892cf1beaf8fad6846a9a60d SHA1 190c87478da079ff59e3827660a70f4693daf202 SHA256 57c8ce101b0c3f41d7a6a4755d6ac1def92f7e3c63dfcd20583921b4f764a2c0
+DIST memtest86+-2.01.tar.gz 165984 RMD160 cdd94d9ea1089387bba8bd024c5cb39b741cba9f SHA1 3420652300e397891af8b263318dc08144e8b4a4 SHA256 35ad452f4fd12f07756abccccf1bce70d42596c2c5e9c29247ffc8e0b76bd1ae
+EBUILD memtest86+-2.01.ebuild 1769 RMD160 5ef1a503dbd4256672b91ef5cad7c400d5b69ca4 SHA1 2856ce768a346a3e3d6bf35affc887b943e585eb SHA256 42d40cfb681978efe903498a23fb88a2f05502a4ff6c7db4aca46ebc4f5dc98c
diff --git a/sys-apps/memtest86+/files/memtest86+-1.70-gnu_hash.patch b/sys-apps/memtest86+/files/memtest86+-1.70-gnu_hash.patch
new file mode 100644
index 0000000..5a9e06d
--- /dev/null
+++ b/sys-apps/memtest86+/files/memtest86+-1.70-gnu_hash.patch
@@ -0,0 +1,11 @@
+diff -Naurp memtest86+-1.70-orig/memtest_shared.lds memtest86+-1.70/memtest_shared.lds
+--- memtest86+-1.70-orig/memtest_shared.lds 2007-01-27 13:34:16.000000000 +0100
++++ memtest86+-1.70/memtest_shared.lds 2007-01-27 13:41:30.000000000 +0100
+@@ -18,6 +18,7 @@ SECTIONS {
+ .dynsym : { *(.dynsym) }
+ .dynstr : { *(.dynstr) }
+ .hash : { *(.hash) }
++ .gnu.hash : { *(.gnu.hash) }
+ .dynamic : { *(.dynamic) }
+
+ .rel.text : { *(.rel.text .rel.text.*) }
diff --git a/sys-apps/memtest86+/files/memtest86+-2.01-hardcoded_cc.patch b/sys-apps/memtest86+/files/memtest86+-2.01-hardcoded_cc.patch
new file mode 100644
index 0000000..3a92f4d
--- /dev/null
+++ b/sys-apps/memtest86+/files/memtest86+-2.01-hardcoded_cc.patch
@@ -0,0 +1,29 @@
+diff -u memtest86+-2.01.orig/Makefile memtest86+-2.01/Makefile
+--- memtest86+-2.01.orig/Makefile 2008-02-21 16:49:24.000000000 +0100
++++ memtest86+-2.01/Makefile 2008-03-11 14:52:12.000000000 +0100
+@@ -9,9 +9,10 @@
+ FDISK=/dev/fd0
+
+ AS=as -32
+-CC=gcc
+
+-CFLAGS=-Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC
++CFLAGS=-Wall -m32 -march=i486 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector
++CPPFLAGS=-m32
++ASFLAGS=-32
+
+ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
+ config.o linuxbios.o memsize.o pci.o controller.o random.o extra.o \
+@@ -47,10 +48,10 @@
+ memtest_shared.bin -o memtest.bin
+
+ reloc.o: reloc.c
+- $(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
++ $(CC) -c $(CFLAGS) -fno-strict-aliasing -fno-stack-protector reloc.c
+
+ test.o: test.c
+- $(CC) -c -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding test.c
++ $(CC) -c -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fno-stack-protector -fno-pie -nopie test.c
+
+ clean:
+ rm -f *.o *.s *.iso memtest.bin memtest memtest_shared memtest_shared.bin
diff --git a/sys-apps/memtest86+/files/memtest86+-2.01-serial-baud.patch b/sys-apps/memtest86+/files/memtest86+-2.01-serial-baud.patch
new file mode 100644
index 0000000..84f822f
--- /dev/null
+++ b/sys-apps/memtest86+/files/memtest86+-2.01-serial-baud.patch
@@ -0,0 +1,12 @@
+diff -u memtest86+-2.01.orig/config.h memtest86+-2.01/config.h
+--- memtest86+-2.01.orig/config.h 2008-02-21 12:26:05.000000000 +0100
++++ memtest86+-2.01/config.h 2008-03-11 14:48:04.000000000 +0100
+@@ -19,7 +19,7 @@
+ #define SERIAL_TTY 0
+
+ /* SERIAL_BAUD_RATE - Baud rate for the serial console */
+-#define SERIAL_BAUD_RATE 9600
++#define SERIAL_BAUD_RATE 115200
+
+ /* BEEP_MODE - Beep on error. Default off, Change to 1 to enable */
+ #define BEEP_MODE 0
diff --git a/sys-apps/memtest86+/memtest86+-2.01.ebuild b/sys-apps/memtest86+/memtest86+-2.01.ebuild
new file mode 100644
index 0000000..290223d
--- /dev/null
+++ b/sys-apps/memtest86+/memtest86+-2.01.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit mount-boot eutils
+
+DESCRIPTION="Memory tester based on memtest86"
+HOMEPAGE="http://www.memtest.org/"
+SRC_URI="http://www.memtest.org/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="serial"
+RESTRICT="test"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-serial-baud.patch
+ epatch "${FILESDIR}"/${P}-hardcoded_cc.patch
+ epatch "${FILESDIR}"/${PN}-1.70-gnu_hash.patch
+
+ if use serial ; then
+ sed -e 's/#define SERIAL_CONSOLE_DEFAULT 0/#define SERIAL_CONSOLE_DEFAULT 1/' -i config.h
+ fi
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ insinto /boot/memtest86plus
+ doins memtest.bin || die
+ dodoc README README.build-process
+}
+
+pkg_postinst() {
+ einfo
+ einfo "memtest.bin has been installed in /boot/memtest86plus/"
+ einfo "You may wish to update your bootloader configs"
+ einfo "by adding these lines:"
+
+ # a little magic to make users' life as easy as possible ;)
+ local fstab=${ROOT}/etc/fstab
+ local root="(hd0,0)"
+ local res=$(awk '$2 == "/boot" {print $1}' "${fstab}")
+ if [[ -z ${res} ]] ; then
+ res=$(awk '$2 == "/" {print $1}' "${fstab}")
+ fi
+ if [[ -n ${res} ]] ; then
+ # transform /dev/hd* magic into grub naming ...
+ # /dev/hda1 -> a1 -> 01
+ root=$(echo "${res}" | grep -o '[a-z][0-9]' | tr -t a-z 0123456789)
+ root="(hd${root:0:1},$((${root:1:1}-1)))"
+ fi
+ einfo " - For grub:"
+ einfo " > title=Memtest86Plus"
+ einfo " > root ${root}"
+ einfo " > kernel /boot/memtest86plus/memtest.bin"
+
+ einfo " - For lilo:"
+ einfo " > image = /boot/memtest86plus/memtest.bin"
+ einfo " > label = Memtest86Plus"
+ einfo
+}