summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/llvmpy/llvmpy-0.11.2.ebuild')
-rw-r--r--dev-python/llvmpy/llvmpy-0.11.2.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/llvmpy/llvmpy-0.11.2.ebuild b/dev-python/llvmpy/llvmpy-0.11.2.ebuild
deleted file mode 100644
index 2bd8985..0000000
--- a/dev-python/llvmpy/llvmpy-0.11.2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_{6,7} python3_{1,2,3} )
-
-inherit eutils distutils-r1
-
-DESCRIPTION="Python wrapper around the llvm C++ library"
-HOMEPAGE="http://llvmpy.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="sys-devel/llvm[multitarget]"
-RDEPEND="${DEPEND}"
-
-python_prepare() {
- epatch "${FILESDIR}"/${P}-rpath.patch
- distutils-r1-python_prepare
-}
-
-python_test() {
- pushd "${BUILD_DIR}"/lib* > /dev/null
- ${PYTHON} -c "import llvm; llvm.test()"
- popd > /dev/null
-}