summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-02-20 17:58:59 +0800
committerBen de Groot <yngwin@gentoo.org>2015-02-20 17:58:59 +0800
commit8f3f8363fcab26f8c8f1a74140680adf1d218029 (patch)
tree11ba301b2a7e9b875593a3a9b6200f1820606252 /app-editors
parentapp-editors/neovim: add snapshot (diff)
downloadyngwin-8f3f8363fcab26f8c8f1a74140680adf1d218029.tar.gz
yngwin-8f3f8363fcab26f8c8f1a74140680adf1d218029.tar.bz2
yngwin-8f3f8363fcab26f8c8f1a74140680adf1d218029.zip
Add neovim-python-client ebuild with dep. Update neovim ebuild.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/Manifest2
-rw-r--r--app-editors/neovim/neovim-0.0.0_pre20150220.ebuild10
-rw-r--r--app-editors/neovim/neovim-9999.ebuild10
3 files changed, 13 insertions, 9 deletions
diff --git a/app-editors/neovim/Manifest b/app-editors/neovim/Manifest
index f1f5853..60ca0fa 100644
--- a/app-editors/neovim/Manifest
+++ b/app-editors/neovim/Manifest
@@ -1 +1 @@
-DIST neovim-0.0.0_pre20150220.tar.gz 7369794 SHA256 78b38d4f0e78b9438f54405aceea717dc08dd5e80d69996654bb2042a829351d SHA512 a9045b22e5e7c60d9a735c05d3a82002a92bc2305453b12b37d6f0f9f3c7317399e414b3606a4f34cc9c92080d32a299a6105560a860cda667c85dbe6a03a204 WHIRLPOOL aedd27ed23640362cbf8b4f7daa9182465397122e9e8a0b8af0e2b7adb9a8028fee1515745e9574d62c0f6256a0e842125f5688a4c185b4a1436410d032d2bc8
+DIST neovim-0.0.0_pre20150220.tar.gz 7369427 SHA256 d6628a2de3f5fea5983a6ee9fa7d3eae4e1d3469ab5948ac4d5f27fd3131229c SHA512 4580539c975848cd94402e045e983ee40e585a515ac4dca343fa6ee354359a74222738b682359c1f98619a70578abaf4e482023fdb9b25ea80dbf6e8cf53a22d WHIRLPOOL f68b1d8512f62f8f3b6c7871642c4b257f6f72ed920e6c91a358180a559b0db87ba5e5758d1849437aa00f14322fe59d6318b071616c22e1e700929332bfa98f
diff --git a/app-editors/neovim/neovim-0.0.0_pre20150220.ebuild b/app-editors/neovim/neovim-0.0.0_pre20150220.ebuild
index 0580e56..7c8bb7d 100644
--- a/app-editors/neovim/neovim-0.0.0_pre20150220.ebuild
+++ b/app-editors/neovim/neovim-0.0.0_pre20150220.ebuild
@@ -13,14 +13,14 @@ if [[ ${PV} == 9999 ]]; then
KEYWORDS=""
else
inherit vcs-snapshot
- COMMIT="866da6d65e5078ac5aa91af5b4e78caf07853379"
+ COMMIT="8efb3607a7f6cefce450953c7f8d5e3299347bae"
SRC_URI="https://github.com/${PN}/${PN}/tarball/${COMMIT} -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="perl"
+IUSE="perl python"
CDEPEND="dev-lang/luajit
>=dev-libs/libtermkey-0.17
@@ -34,10 +34,12 @@ DEPEND="${CDEPEND}
virtual/libiconv
virtual/libintl"
RDEPEND="${CDEPEND}
- perl? ( dev-lang/perl )"
+ perl? ( dev-lang/perl )
+ python? ( dev-python/neovim-python-client )"
src_configure() {
- append-flags "-Wno-error -DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
+ append-cflags "-Wno-error"
+ append-cppflags "-DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
local mycmakeargs=( -DCMAKE_BUILD_TYPE=Release )
cmake-utils_src_configure
}
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 0580e56..7c8bb7d 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -13,14 +13,14 @@ if [[ ${PV} == 9999 ]]; then
KEYWORDS=""
else
inherit vcs-snapshot
- COMMIT="866da6d65e5078ac5aa91af5b4e78caf07853379"
+ COMMIT="8efb3607a7f6cefce450953c7f8d5e3299347bae"
SRC_URI="https://github.com/${PN}/${PN}/tarball/${COMMIT} -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="perl"
+IUSE="perl python"
CDEPEND="dev-lang/luajit
>=dev-libs/libtermkey-0.17
@@ -34,10 +34,12 @@ DEPEND="${CDEPEND}
virtual/libiconv
virtual/libintl"
RDEPEND="${CDEPEND}
- perl? ( dev-lang/perl )"
+ perl? ( dev-lang/perl )
+ python? ( dev-python/neovim-python-client )"
src_configure() {
- append-flags "-Wno-error -DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
+ append-cflags "-Wno-error"
+ append-cppflags "-DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
local mycmakeargs=( -DCMAKE_BUILD_TYPE=Release )
cmake-utils_src_configure
}