summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-07-26 15:36:15 +0800
committerBen de Groot <yngwin@gentoo.org>2012-07-26 15:36:15 +0800
commitc519bd0506a47eb82dfb0887f5e7313590ad4342 (patch)
treefb239ca3964ebfe1a48e119074f966f1f557a1ac /app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild
parentnet-im/qtwitter: rm since changes applied in gx86 (diff)
downloadyngwin-c519bd0506a47eb82dfb0887f5e7313590ad4342.tar.gz
yngwin-c519bd0506a47eb82dfb0887f5e7313590ad4342.tar.bz2
yngwin-c519bd0506a47eb82dfb0887f5e7313590ad4342.zip
app-vim/gentoo-syntax: live ebuild adapted from floppym overlay
Diffstat (limited to 'app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild')
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild
new file mode 100644
index 0000000..4d02d9d
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit git-2 vim-plugin
+
+DESCRIPTION="Vim syntax highlighting, filetype and indent settings for Gentoo filetypes"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/gentoo-syntax.git
+ http://git.overlays.gentoo.org/proj/gentoo-syntax.git"
+
+LICENSE="vim"
+KEYWORDS=""
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+ rm -r .git Makefile || die
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+}