summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-06-27 21:50:16 +0800
committerBen de Groot <yngwin@gentoo.org>2012-06-27 21:50:16 +0800
commit656353dae534ae811835011c1a1aa9e1e78049f6 (patch)
tree297dd4aa974efd292784af080495051204c782a3 /www-apps
downloadyngwin-656353dae534ae811835011c1a1aa9e1e78049f6.tar.gz
yngwin-656353dae534ae811835011c1a1aa9e1e78049f6.tar.bz2
yngwin-656353dae534ae811835011c1a1aa9e1e78049f6.zip
Initial commit. Set up repo, add live nikola ebuild
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/nikola/metadata.xml9
-rw-r--r--www-apps/nikola/nikola-9999.ebuild34
2 files changed, 43 insertions, 0 deletions
diff --git a/www-apps/nikola/metadata.xml b/www-apps/nikola/metadata.xml
new file mode 100644
index 0000000..9e2b2f1
--- /dev/null
+++ b/www-apps/nikola/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ <name>Ben de Groot</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/www-apps/nikola/nikola-9999.ebuild b/www-apps/nikola/nikola-9999.ebuild
new file mode 100644
index 0000000..892c6e9
--- /dev/null
+++ b/www-apps/nikola/nikola-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_COMPAT="python2_6 python2_7"
+
+inherit git-2 python-distutils-ng
+
+DESCRIPTION="A static website and blog generator"
+HOMEPAGE="http://nikola.ralsina.com.ar/"
+#SRC_URI="http://nikola-generator.googlecode.com/files/${P}.zip"
+EGIT_REPO_URI="git://github.com/ralsina/nikola.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-python/docutils
+ dev-python/doit
+ dev-python/imaging
+ >=dev-python/mako-0.6
+ dev-python/pygments"
+
+src_install() {
+ python-distutils-ng_src_install
+
+ # hackish way to remove docs that ended up in the wrong place
+ rm "${D}"/usr/*.txt
+
+ dodoc README.md docs/*
+}