aboutsummaryrefslogtreecommitdiff
path: root/gdb
diff options
context:
space:
mode:
authorChristian Biesinger <cbiesinger@google.com>2019-10-31 18:24:07 -0500
committerChristian Biesinger <cbiesinger@google.com>2019-11-01 10:13:44 -0500
commite48f6033b01b6a5832e1efa48eda4e44193067a7 (patch)
tree27b777bc7b1ff60b6562df6f8eeab309c3be1a25 /gdb
parent[ARM, thumb] Fix disassembling bug after reloading a symbol file (diff)
downloadbinutils-gdb-e48f6033b01b6a5832e1efa48eda4e44193067a7.tar.gz
binutils-gdb-e48f6033b01b6a5832e1efa48eda4e44193067a7.tar.bz2
binutils-gdb-e48f6033b01b6a5832e1efa48eda4e44193067a7.zip
Move check for strerror_r to common.m4 where it belongs
gdb/ChangeLog: 2019-11-01 Christian Biesinger <cbiesinger@google.com> * configure: Regenerate. * configure.ac: Remove check for strerror_r. * gdbsupport/common.m4: Check for strerror_r. gdb/gdbserver/ChangeLog: 2019-11-01 Christian Biesinger <cbiesinger@google.com> * configure: Regenerate. * configure.ac: Remove check for strerror_r. Change-Id: Ibc290c3f84b1db23e998cffdbe2c1f97651d2a8d
Diffstat (limited to 'gdb')
-rw-r--r--gdb/ChangeLog6
-rwxr-xr-xgdb/configure4
-rw-r--r--gdb/configure.ac2
-rw-r--r--gdb/gdbserver/ChangeLog5
-rwxr-xr-xgdb/gdbserver/configure4
-rw-r--r--gdb/gdbserver/configure.ac2
-rw-r--r--gdb/gdbsupport/common.m42
7 files changed, 18 insertions, 7 deletions
diff --git a/gdb/ChangeLog b/gdb/ChangeLog
index e2bdd5f3e9c..4231ac11fe6 100644
--- a/gdb/ChangeLog
+++ b/gdb/ChangeLog
@@ -1,3 +1,9 @@
+2019-11-01 Christian Biesinger <cbiesinger@google.com>
+
+ * configure: Regenerate.
+ * configure.ac: Remove check for strerror_r.
+ * gdbsupport/common.m4: Check for strerror_r.
+
2019-11-01 Luis Machado <luis.machado@linaro.org>
PR gdb/25124
diff --git a/gdb/configure b/gdb/configure
index 018cc4ba435..512f0162ff2 100755
--- a/gdb/configure
+++ b/gdb/configure
@@ -13073,7 +13073,7 @@ for ac_func in getauxval getrusage getuid getgid \
sigaction sigsetmask socketpair \
ttrace wborder wresize setlocale iconvlist libiconvlist btowc \
setrlimit getrlimit posix_madvise waitpid \
- ptrace64 sigaltstack setns use_default_colors strerror_r
+ ptrace64 sigaltstack setns use_default_colors
do :
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
@@ -13480,7 +13480,7 @@ done
for ac_func in fdwalk getrlimit pipe pipe2 socketpair sigaction \
- sigprocmask
+ sigprocmask strerror_r
do :
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 987507a17d7..354bb7b4b68 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1318,7 +1318,7 @@ AC_CHECK_FUNCS([getauxval getrusage getuid getgid \
sigaction sigsetmask socketpair \
ttrace wborder wresize setlocale iconvlist libiconvlist btowc \
setrlimit getrlimit posix_madvise waitpid \
- ptrace64 sigaltstack setns use_default_colors strerror_r])
+ ptrace64 sigaltstack setns use_default_colors])
AM_LANGINFO_CODESET
GDB_AC_COMMON
diff --git a/gdb/gdbserver/ChangeLog b/gdb/gdbserver/ChangeLog
index ab03f8815d7..35684dbe82e 100644
--- a/gdb/gdbserver/ChangeLog
+++ b/gdb/gdbserver/ChangeLog
@@ -1,3 +1,8 @@
+2019-11-01 Christian Biesinger <cbiesinger@google.com>
+
+ * configure: Regenerate.
+ * configure.ac: Remove check for strerror_r.
+
2019-10-31 Christian Biesinger <cbiesinger@google.com>
* config.in: Regenerate.
diff --git a/gdb/gdbserver/configure b/gdb/gdbserver/configure
index 7bf9fa23dad..3f1f1c19ba4 100755
--- a/gdb/gdbserver/configure
+++ b/gdb/gdbserver/configure
@@ -6448,7 +6448,7 @@ $as_echo "#define HAVE_WORKING_FORK 1" >>confdefs.h
fi
-for ac_func in getauxval pread pwrite pread64 setns strerror_r
+for ac_func in getauxval pread pwrite pread64 setns
do :
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
@@ -6822,7 +6822,7 @@ done
for ac_func in fdwalk getrlimit pipe pipe2 socketpair sigaction \
- sigprocmask
+ sigprocmask strerror_r
do :
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
diff --git a/gdb/gdbserver/configure.ac b/gdb/gdbserver/configure.ac
index 44fee8ba4f2..7ebc9c3cf15 100644
--- a/gdb/gdbserver/configure.ac
+++ b/gdb/gdbserver/configure.ac
@@ -90,7 +90,7 @@ AC_CHECK_HEADERS(termios.h sys/reg.h string.h dnl
sys/ioctl.h netinet/in.h sys/socket.h netdb.h dnl
netinet/tcp.h arpa/inet.h)
AC_FUNC_FORK
-AC_CHECK_FUNCS(getauxval pread pwrite pread64 setns strerror_r)
+AC_CHECK_FUNCS(getauxval pread pwrite pread64 setns)
GDB_AC_COMMON
diff --git a/gdb/gdbsupport/common.m4 b/gdb/gdbsupport/common.m4
index 471d7056f74..2e44cf45368 100644
--- a/gdb/gdbsupport/common.m4
+++ b/gdb/gdbsupport/common.m4
@@ -33,7 +33,7 @@ AC_DEFUN([GDB_AC_COMMON], [
dlfcn.h)
AC_CHECK_FUNCS([fdwalk getrlimit pipe pipe2 socketpair sigaction \
- sigprocmask])
+ sigprocmask strerror_r])
AC_CHECK_DECLS([strerror, strstr])