aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Oreman <oremanj@hudson-trading.com>2019-05-11 07:27:10 +0800
committerCary Coutant <ccoutant@gmail.com>2019-05-11 07:27:10 +0800
commite173ea00c2941af42ea4e2267446d6039a70da6e (patch)
treec4e71d797a234be5ce51cc9e18c3d922384e7a7e /gold/options.h
parentFix GDB build when using --disable-gdbmi (diff)
downloadbinutils-gdb-e173ea00c2941af42ea4e2267446d6039a70da6e.tar.gz
binutils-gdb-e173ea00c2941af42ea4e2267446d6039a70da6e.tar.bz2
binutils-gdb-e173ea00c2941af42ea4e2267446d6039a70da6e.zip
Fix problem with ICF where diffs in EH frame info is ignored.
PR gold/21066 * gc.h (gc_process_relocs): Track relocations in .eh_frame sections when ICF is enabled, even though the .eh_frame sections themselves are not foldable. * icf.cc (get_section_contents): Change arguments to permit operation on just part of a section. Include extra identity regions in the referring section's contents recursively. (match_sections): Lock object here instead of in get_section_contents so that get_section_contents can operate recursively. (Icf::add_ehframe_links): New method. (Icf::find_identical_sections): Pass .eh_frame sections to add_ehframe_links(). Increase default iteration count from 2 to 3 because handling exception info typically requires one extra iteration. * icf.h (Icf::extra_identity_list_): New data member with accessor. (is_section_foldable_candidate): Include .gcc_except_table sections. * options.h: Update documentation for new default ICF iteration count. * testsuite/Makefile.am (icf_test_pr21066): New test case. * testsuite/Makefile.in: Regenerate. * testsuite/icf_test_pr21066.cc: New source file. * testsuite/icf_test_pr21066.sh: New test script.
Diffstat (limited to 'gold/options.h')
-rw-r--r--gold/options.h2
1 files changed, 1 insertions, 1 deletions
diff --git a/gold/options.h b/gold/options.h
index 5ca89bd1d02..f7c127953c2 100644
--- a/gold/options.h
+++ b/gold/options.h
@@ -946,7 +946,7 @@ class General_options
{"none", "all", "safe"});
DEFINE_uint(icf_iterations, options::TWO_DASHES , '\0', 0,
- N_("Number of iterations of ICF (default 2)"), N_("COUNT"));
+ N_("Number of iterations of ICF (default 3)"), N_("COUNT"));
DEFINE_special(incremental, options::TWO_DASHES, '\0',
N_("Do an incremental link if possible; "