aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-04 03:38:19 +0000
committerMichał Górny <mgorny@gentoo.org>2022-11-04 18:38:37 +0100
commit3641763e5fd77fcfc8562bbaba3baa8b3557fc67 (patch)
tree6d2f01b9172d1671255fd4a3d2cab6b2f80a4065
parentbpo-46756: Fix authorization check in urllib.request (GH-31353) (diff)
downloadcpython-gentoo-2.7-vanilla.tar.gz
cpython-gentoo-2.7-vanilla.tar.bz2
cpython-gentoo-2.7-vanilla.zip
Fix -Wimplicit-int, -Wimplicit-function-declarationgentoo-2.7-vanilla
These warnings became fatal by default in Clang 16. Most of this has since been fixed upstream but https://github.com/python/cpython/pull/99085 is pending. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index efe6922b5d..0ae6adcae1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2792,11 +2792,12 @@ if test "$posix_threads" = "yes"; then
AC_CACHE_VAL(ac_cv_pthread_system_supported,
[AC_RUN_IFELSE([AC_LANG_SOURCE([[
#include <stdio.h>
+ #include <stdlib.h>
#include <pthread.h>
void *foo(void *parm) {
return NULL;
}
- main() {
+ int main() {
pthread_attr_t attr;
pthread_t id;
if (pthread_attr_init(&attr)) exit(-1);
@@ -4155,6 +4156,7 @@ then
AC_MSG_CHECKING(whether wchar_t is signed)
AC_CACHE_VAL(ac_cv_wchar_t_signed, [
AC_RUN_IFELSE([AC_LANG_SOURCE([[
+ #include <stdlib.h>
#include <wchar.h>
int main()
{
@@ -4244,6 +4246,7 @@ AC_C_BIGENDIAN
AC_MSG_CHECKING(whether right shift extends the sign bit)
AC_CACHE_VAL(ac_cv_rshift_extends_sign, [
AC_RUN_IFELSE([AC_LANG_SOURCE([[
+#include <stdlib.h>
int main()
{
exit(((-1)>>3 == -1) ? 0 : 1);