aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@redhat.com>2018-10-26 15:10:29 +0200
committerGitHub <noreply@github.com>2018-10-26 15:10:29 +0200
commita05bef4f5be1bcd0df63ec0eb88b64fdde593a86 (patch)
tree76c8f808b726577da068c235a6d28ecfdce323ad /PCbuild/pyproject.props
parentbpo-35059: Convert PyObject_INIT() to function (GH-10077) (diff)
downloadcpython-a05bef4f5be1bcd0df63ec0eb88b64fdde593a86.tar.gz
cpython-a05bef4f5be1bcd0df63ec0eb88b64fdde593a86.tar.bz2
cpython-a05bef4f5be1bcd0df63ec0eb88b64fdde593a86.zip
bpo-35059, PCbuild: Expand inline funcs in Debug (GH-10094)
Visual Studio solution: Set InlineFunctionExpansion to OnlyExplicitInline ("/Ob1" option) on all projects (in pyproject.props) in Debug mode on Win32 and x64 platforms to expand functions marked as inline. This change should make Python compiled in Debug mode a little bit faster on Windows. On Unix, GCC uses -Og optimization level for ./configure --with-pydebug.
Diffstat (limited to 'PCbuild/pyproject.props')
-rw-r--r--PCbuild/pyproject.props2
1 files changed, 2 insertions, 0 deletions
diff --git a/PCbuild/pyproject.props b/PCbuild/pyproject.props
index 6d36977456e..95b349c077e 100644
--- a/PCbuild/pyproject.props
+++ b/PCbuild/pyproject.props
@@ -42,6 +42,8 @@
<SuppressStartupBanner>true</SuppressStartupBanner>
<WholeProgramOptimization>true</WholeProgramOptimization>
<EnableEnhancedInstructionSet Condition="'$(Platform)'=='Win32'">NoExtensions</EnableEnhancedInstructionSet>
+ <InlineFunctionExpansion Condition="'$(Configuration)|$(Platform)'=='Debug|Win32'">OnlyExplicitInline</InlineFunctionExpansion>
+ <InlineFunctionExpansion Condition="'$(Configuration)|$(Platform)'=='Debug|x64'">OnlyExplicitInline</InlineFunctionExpansion>
</ClCompile>
<ClCompile Condition="$(Configuration) == 'Debug'">
<Optimization>Disabled</Optimization>