aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristján Valur Jónsson <kristjan@ccpgames.com>2012-05-19 21:10:14 +0000
committerKristján Valur Jónsson <kristjan@ccpgames.com>2012-05-19 21:10:14 +0000
commitc45ea9ebc774d46260230a76e5b8c3c1de020250 (patch)
treed7d15cba51f5f49bb73c99a2822fb8ef8597d7d9 /PCbuild/pyproject.props
parentClose #14588: added a PEP 3115 compliant dynamic type creation mechanism (diff)
downloadcpython-c45ea9ebc774d46260230a76e5b8c3c1de020250.tar.gz
cpython-c45ea9ebc774d46260230a76e5b8c3c1de020250.tar.bz2
cpython-c45ea9ebc774d46260230a76e5b8c3c1de020250.zip
Clean up the PCBuild project files, removing redundant settings and
use "references" to link to dependent projects. Update readme and batch files.
Diffstat (limited to 'PCbuild/pyproject.props')
-rw-r--r--PCbuild/pyproject.props11
1 files changed, 7 insertions, 4 deletions
diff --git a/PCbuild/pyproject.props b/PCbuild/pyproject.props
index f466a0700f3..fba778aec9c 100644
--- a/PCbuild/pyproject.props
+++ b/PCbuild/pyproject.props
@@ -1,8 +1,9 @@
<?xml version="1.0" encoding="utf-8"?>
<Project DefaultTargets="Build" ToolsVersion="4.0" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
<PropertyGroup Label="UserMacros">
- <PyDllName>python33</PyDllName>
- <PythonExe>$(SolutionDir)\python.exe</PythonExe>
+ <PyDllName>python33$(PyDebugExt)</PyDllName>
+ <PythonExe>$(SolutionDir)python$(PyDebugExt).exe</PythonExe>
+ <KillPythonExe>$(OutDir)kill_python$(PyDebugExt).exe</KillPythonExe>
<externalsDir>..\..</externalsDir>
<sqlite3Dir>$(externalsDir)\sqlite-3.7.12</sqlite3Dir>
<bz2Dir>$(externalsDir)\bzip2-1.0.6</bz2Dir>
@@ -17,10 +18,9 @@
</PropertyGroup>
<PropertyGroup>
<_ProjectFileVersion>10.0.30319.1</_ProjectFileVersion>
- <OutDir>$(SolutionDir)\</OutDir>
+ <OutDir>$(SolutionDir)</OutDir>
<IntDir>$(SolutionDir)$(PlatformName)-temp-$(Configuration)\$(ProjectName)\</IntDir>
<LinkIncremental>false</LinkIncremental>
- <TargetExt>.dll</TargetExt>
</PropertyGroup>
<ItemDefinitionGroup>
<ClCompile>
@@ -59,6 +59,9 @@
<BuildMacro Include="PythonExe">
<Value>$(PythonExe)</Value>
</BuildMacro>
+ <BuildMacro Include="KillPythonExe">
+ <Value>$(KillPythonExe)</Value>
+ </BuildMacro>
<BuildMacro Include="externalsDir">
<Value>$(externalsDir)</Value>
</BuildMacro>