aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpxinwr <peixing.xin@windriver.com>2020-12-30 20:50:39 +0800
committerGitHub <noreply@github.com>2020-12-30 13:50:39 +0100
commit277ce3060becc120f1c877346562bd6880f4be71 (patch)
treec0cf4a259865653e84f5d4a87ae2e27e7cb20dbc /configure.ac
parentbpo-27794: Add `name` attribute to `property` class (GH-23967) (diff)
downloadcpython-277ce3060becc120f1c877346562bd6880f4be71.tar.gz
cpython-277ce3060becc120f1c877346562bd6880f4be71.tar.bz2
cpython-277ce3060becc120f1c877346562bd6880f4be71.zip
bpo-27640: Add --disable-test-modules configure option (GH-23886)
Added --disable-test-modules option to the configure script: don't build nor install test modules. Patch by Xavier de Gaye, Thomas Petazzoni and Peixing Xin. Co-Authored-By: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Co-Authored-By: Xavier de Gaye <xdegaye@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 39eadfedfb..990d6bfdd8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5834,6 +5834,20 @@ else
fi],
[AC_MSG_RESULT(no)])
+# Check whether to disable test modules. Once set, setup.py will not build
+# test extension modules and "make install" will not install test suites.
+AC_MSG_CHECKING(for --disable-test-modules)
+AC_ARG_ENABLE(test-modules,
+ AS_HELP_STRING([--disable-test-modules], [don't build nor install test modules]))
+if test "$enable_test_modules" = no; then
+ TEST_MODULES=no
+ AC_MSG_RESULT(yes)
+else
+ TEST_MODULES=yes
+ AC_MSG_RESULT(no)
+fi
+AC_SUBST(TEST_MODULES)
+
# generate output files
AC_CONFIG_FILES(Makefile.pre Misc/python.pc Misc/python-embed.pc Misc/python-config.sh)
@@ -5860,4 +5874,3 @@ if test "$Py_OPT" = 'false' -a "$Py_DEBUG" != 'true'; then
echo "" >&AS_MESSAGE_FD
echo "" >&AS_MESSAGE_FD
fi
-