aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2019-09-10 11:37:59 +0100
committerT. Wouters <thomas@python.org>2019-09-10 03:37:59 -0700
commitf1c19031fd5f4cf6faad539e30796b42954527db (patch)
treee891a6fb68b448b3f15998f0bd1ce7f509fa004e /configure.ac
parentbpo-37052: Add examples for mocking async iterators and context managers (GH-... (diff)
downloadcpython-f1c19031fd5f4cf6faad539e30796b42954527db.tar.gz
cpython-f1c19031fd5f4cf6faad539e30796b42954527db.tar.bz2
cpython-f1c19031fd5f4cf6faad539e30796b42954527db.zip
bpo-38068: Clean up gettimeofday configure logic. (GH-15775)
Assume gettimeofday exists and takes two arguments.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 0 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 43514129dd5..9f5cea5ca0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3865,15 +3865,6 @@ AC_CHECK_FUNCS(setpgrp,
[AC_DEFINE(SETPGRP_HAVE_ARG, 1, [Define if setpgrp() must be called as setpgrp(0, 0).])],
[])
)
-AC_CHECK_FUNCS(gettimeofday,
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/time.h>]],
- [[gettimeofday((struct timeval*)0,(struct timezone*)0);]])],
- [],
- [AC_DEFINE(GETTIMEOFDAY_NO_TZ, 1,
- [Define if gettimeofday() does not have second (timezone) argument
- This is the case on Motorola V4 (R40V4.2)])
- ])
-)
# We search for both crypt and crypt_r as one or the other may be defined
# This gets us our -lcrypt in LIBS when required on the target platform.