aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeil Schemenauer <nas-github@arctrix.com>2019-02-08 10:48:46 -0800
committerGitHub <noreply@github.com>2019-02-08 10:48:46 -0800
commit5741c45acf9b0ce22ff0dbf56322fe0ff16cfcfc (patch)
tree783c08f9a90d37d478e235bc37ecec499cbd7a78 /pyconfig.h.in
parentComplete and neaten-up namedtuple's replacement of builtin function lookups w... (diff)
downloadcpython-5741c45acf9b0ce22ff0dbf56322fe0ff16cfcfc.tar.gz
cpython-5741c45acf9b0ce22ff0dbf56322fe0ff16cfcfc.tar.bz2
cpython-5741c45acf9b0ce22ff0dbf56322fe0ff16cfcfc.zip
bpo-35903: Use autoconfig to probe for shm_open() and shm_unlink(). (#11765)
Use autoconfig to probe for shm_open() and shm_unlink(). Set SHM_NEEDS_LIBRT if we must link with librt to get the shm_* functions. Change setup.py to use the autoconfig defines. These changes should make it more likely that _multiprocessing/posixshmem.c gets built correctly on different platforms.
Diffstat (limited to 'pyconfig.h.in')
-rw-r--r--pyconfig.h.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/pyconfig.h.in b/pyconfig.h.in
index a2a56230fc..ab9e9e10f7 100644
--- a/pyconfig.h.in
+++ b/pyconfig.h.in
@@ -144,6 +144,18 @@
/* Define to 1 if you have the `copysign' function. */
#undef HAVE_COPYSIGN
+/* Define to 1 if you must link with -lrt for shm_open(). */
+#undef SHM_NEEDS_LIBRT
+
+/* Define to 1 if you have the <sys/mman.h> header file. */
+#undef HAVE_SYS_MMAN_H
+
+/* Define to 1 if you have the shm_open syscall */
+#undef HAVE_SHM_OPEN
+
+/* Define to 1 if you have the shm_unlink syscall */
+#undef HAVE_SHM_UNLINK
+
/* Define to 1 if you have the <crypt.h> header file. */
#undef HAVE_CRYPT_H