aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2020-06-16 01:28:07 +0200
committerGitHub <noreply@github.com>2020-06-16 01:28:07 +0200
commit04fc4f2a46b2fd083639deb872c3a3037fdb47d6 (patch)
tree3fc5a585683e09748fb3113c34cfa42e8bf634b2 /setup.py
parentbpo-36020: Require vsnprintf() to build Python (GH-20899) (diff)
downloadcpython-04fc4f2a46b2fd083639deb872c3a3037fdb47d6.tar.gz
cpython-04fc4f2a46b2fd083639deb872c3a3037fdb47d6.tar.bz2
cpython-04fc4f2a46b2fd083639deb872c3a3037fdb47d6.zip
bpo-40989: PyObject_INIT() becomes an alias to PyObject_Init() (GH-20901)
The PyObject_INIT() and PyObject_INIT_VAR() macros become aliases to, respectively, PyObject_Init() and PyObject_InitVar() functions. Rename _PyObject_INIT() and _PyObject_INIT_VAR() static inline functions to, respectively, _PyObject_Init() and _PyObject_InitVar(), and move them to pycore_object.h. Remove their return value: their return type becomes void. The _datetime module is now built with the Py_BUILD_CORE_MODULE macro defined. Remove an outdated comment on _Py_tracemalloc_config.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ef2faf613b..b220f5279c 100644
--- a/setup.py
+++ b/setup.py
@@ -853,7 +853,8 @@ class PyBuildExt(build_ext):
# libm is needed by delta_new() that uses round() and by accum() that
# uses modf().
self.add(Extension('_datetime', ['_datetimemodule.c'],
- libraries=['m']))
+ libraries=['m'],
+ extra_compile_args=['-DPy_BUILD_CORE_MODULE']))
# zoneinfo module
self.add(Extension('_zoneinfo', ['_zoneinfo.c'])),
# random number generator implemented in C