aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErlend Egeberg Aasland <erlend.aasland@innova.no>2021-01-06 01:02:43 +0100
committerGitHub <noreply@github.com>2021-01-06 02:02:43 +0200
commitcf0b23908cc902ac38cd83dd7ca5afdf89e1543b (patch)
tree213330fcd0db5954b3937e913a168fc7f68ebf4b /setup.py
parentbpo-40956: Convert _sqlite3.Cursor to Argument Clinic (GH-24007) (diff)
downloadcpython-cf0b23908cc902ac38cd83dd7ca5afdf89e1543b.tar.gz
cpython-cf0b23908cc902ac38cd83dd7ca5afdf89e1543b.tar.bz2
cpython-cf0b23908cc902ac38cd83dd7ca5afdf89e1543b.zip
bpo-40810: Require SQLite 3.7.15 (GH-24106)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 8598d2aa5db..ddc0bd067d4 100644
--- a/setup.py
+++ b/setup.py
@@ -1444,8 +1444,7 @@ class PyBuildExt(build_ext):
]
if CROSS_COMPILING:
sqlite_inc_paths = []
- # We need to find >= sqlite version 3.7.3, for sqlite3_create_function_v2()
- MIN_SQLITE_VERSION_NUMBER = (3, 7, 3)
+ MIN_SQLITE_VERSION_NUMBER = (3, 7, 15) # Issue 40810
MIN_SQLITE_VERSION = ".".join([str(x)
for x in MIN_SQLITE_VERSION_NUMBER])