aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndré Erdmann <dywi@mailerd.de>2012-06-11 20:13:34 +0200
committerAndré Erdmann <dywi@mailerd.de>2012-06-11 20:13:34 +0200
commit59f85a10249a6382fbcd23bcf90d2669f724ce18 (patch)
tree8728d5ce813c1268f22b4e1374138d11238fc276 /Makefile
parentreadability / comments / minor fixes (diff)
downloadR_overlay-59f85a10249a6382fbcd23bcf90d2669f724ce18.tar.gz
R_overlay-59f85a10249a6382fbcd23bcf90d2669f724ce18.tar.bz2
R_overlay-59f85a10249a6382fbcd23bcf90d2669f724ce18.zip
Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 16f43e4..443e66b 100644
--- a/Makefile
+++ b/Makefile
@@ -5,14 +5,23 @@ EXAMPLES = ./examples
PYVER = 3
PY = python$(PYVER)
+LOGDIR = ./log
+
PY_NOP = ./nop.py
PY_EBU = ./run_ebuildcreation.py
PY_EBU2 = ./test_ebuildcreation.sh
-.PHONY: default dummy test test-nop test-ebuild_creation test-ebuild_creation2 test-seewave seewave
+.PHONY: default dummy test test-nop \
+ test-ebuild_creation \
+ test-ebuild_creation2 \
+ test-ebuild_creation3 \
+ test-seewave seewave
default: dummy test
+$(LOGDIR):
+ mkdir -v $(LOGDIR)
+
dummy:
$(PY) --version
@@ -21,7 +30,7 @@ seewave: test-seewave
test-seewave: test-nop $(PY_EBU) $(EXAMPLES)/packages
$(PY) $(PY_EBU) $(EXAMPLES)/packages/seewave_*.tar.gz
-test-nop: $(PY_NOP)
+test-nop: $(PY_NOP) $(LOGDIR)
@$(PY) $(PY_NOP)
# test-desc (file) has been removed in favor of test-desc (tar),
@@ -30,6 +39,9 @@ test-ebuild_creation: test-nop $(PY_EBU) $(EXAMPLES)/packages
$(PY) $(PY_EBU) $(EXAMPLES)/packages/*.tar.gz
test-ebuild_creation2: test-nop $(PY_EBU) $(PY_EBU2) $(EXAMPLES)/packages /bin/bash
+ PYTHON=$(PY) /bin/bash $(PY_EBU2) -q 100
+
+test-ebuild_creation3: test-nop $(PY_EBU) $(PY_EBU2) $(EXAMPLES)/packages /bin/bash
PYTHON=$(PY) /bin/bash $(PY_EBU2) -q 1000
test: test-nop test-ebuild_creation test-ebuild_creation2 test-seewave