aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndré Erdmann <dywi@mailerd.de>2012-06-01 16:58:36 +0200
committerAndré Erdmann <dywi@mailerd.de>2012-06-01 16:58:36 +0200
commit8c6654317cc7d17cdb6014b30d1d8c51cbbfa32a (patch)
tree8ba7e55e5e4361c4a016e22066b0ee3f81fcfb68 /Makefile
parent2012-01-06: (diff)
downloadR_overlay-8c6654317cc7d17cdb6014b30d1d8c51cbbfa32a.tar.gz
R_overlay-8c6654317cc7d17cdb6014b30d1d8c51cbbfa32a.tar.bz2
R_overlay-8c6654317cc7d17cdb6014b30d1d8c51cbbfa32a.zip
temporary files: test scripts
* removed test-desc from Makefile and added test-ebuild_creation2 * added PYTHON=2|3 to test_ebuildcreation.sh modified: Makefile modified: test_ebuildcreation.sh
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 10911c0..abc4fe8 100644
--- a/Makefile
+++ b/Makefile
@@ -5,12 +5,11 @@ EXAMPLES = ./examples
PYVER = 3
PY = python$(PYVER)
-PY_DESC_TESTER = ./run_descreader.py
PY_NOP = ./nop.py
PY_EBU = ./run_ebuildcreation.py
+PY_EBU2 = ./test_ebuildcreation.sh
-.PHONY: default dummy test test-nop \
- test-ebuild_creation test-desc
+.PHONY: default dummy test test-nop test-ebuild_creation test-ebuild_creation2
default: dummy test
@@ -25,7 +24,7 @@ test-nop: $(PY_NOP)
test-ebuild_creation: test-nop $(PY_EBU) $(EXAMPLES)/packages
$(PY) $(PY_EBU) $(EXAMPLES)/packages/*.tar.gz
-test-desc: test-nop $(PY_DESC_TESTER) $(EXAMPLES)/packages
- $(PY) $(PY_DESC_TESTER) $(EXAMPLES)/packages/*.tar.gz
+test-ebuild_creation2: test-nop $(PY_EBU) $(PY_EBU2) $(EXAMPLES)/packages /bin/bash
+ PYTHON=$(PY) /bin/bash $(PY_EBU2) -q 1000
-test: test-nop test-desc test-ebuild_creation
+test: test-nop test-ebuild_creation test-ebuild_creation2