aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndré Erdmann <dywi@mailerd.de>2013-07-10 15:39:46 +0200
committerAndré Erdmann <dywi@mailerd.de>2013-07-10 15:39:46 +0200
commitafd77696349d7d68ad26680564e00e62943f05cf (patch)
treee384b3545ebaa7e972cb9bd720f0b0ef85244e32 /roverlay-9999.ebuild
parentscripts/: generate setup.py (diff)
downloadR_overlay-afd77696349d7d68ad26680564e00e62943f05cf.tar.gz
R_overlay-afd77696349d7d68ad26680564e00e62943f05cf.tar.bz2
R_overlay-afd77696349d7d68ad26680564e00e62943f05cf.zip
update ebuild, Makefile
Diffstat (limited to 'roverlay-9999.ebuild')
-rw-r--r--roverlay-9999.ebuild37
1 files changed, 21 insertions, 16 deletions
diff --git a/roverlay-9999.ebuild b/roverlay-9999.ebuild
index 68c23fe..40266c8 100644
--- a/roverlay-9999.ebuild
+++ b/roverlay-9999.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI=4
+
# python < 2.7 is not supported
PYTHON_COMPAT="python2_7 python3_1 python3_2"
+PYTHON_USE="ssl"
inherit base python-distutils-ng git-2
@@ -14,39 +16,42 @@ DESCRIPTION="Automatically generated overlay of R packages (SoC2012)"
HOMEPAGE="http://git.overlays.gentoo.org/gitweb/?p=proj/R_overlay.git;a=summary"
SRC_URI=""
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
-IUSE="bzip2"
+IUSE="bzip2 +prebuilt-documentation"
KEYWORDS=""
-DEPEND=""
-RDEPEND="${DEPEND:-}
+DEPEND="!prebuilt-documentation? ( >=dev-python/docutils-0.9 )"
+RDEPEND="
sys-apps/portage
virtual/python-argparse
"
-_CONFDIR=/etc/${PN}
-
python_prepare_all() {
if use bzip2; then
einfo "USE=bzip2: Compressing dependency rule files"
- bzip2 config/simple-deprules.d/* || die "Cannot compress dependency rules!"
+ emake BUILDDIR="${S}/tmp" compress-config
fi
sed -f misc/sed_expression_roverlay_installed roverlay.py -i || \
die "sed expression, roverlay.py"
base_src_prepare
}
+src_compile() {
+ python-distutils-ng_src_compile
+
+ if ! use prebuilt-documentation; then
+ emake htmldoc
+ fi
+}
+
python_install_all() {
- newbin roverlay.py roverlay
+ #newbin roverlay.py roverlay
- insinto "${_CONFDIR}"
- doins config/description_fields.conf config/repo.list
- doins -r config/simple-deprules.d/
- doins -r files/eclass/
- newins config/R-overlay.conf.install R-overlay.conf
+ # hooks etc. into /usr/share (architecture-independent data)
+ emake BUILDDIR="${S}/tmp" DESTDIR="${D}" \
+ install-data $(usex bzip2 install-config{-compressed,})
- doman doc/man/roverlay.1
dohtml doc/html/*
}