summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Hajdan, Jr <phajdan.jr@gentoo.org>2011-12-01 19:47:26 +0100
committerPawel Hajdan, Jr <phajdan.jr@gentoo.org>2011-12-01 19:47:26 +0100
commit19044e7c148d10a58c47476582925fbab10b574b (patch)
tree2b4339c26dc0b8a4a78066dccfa0a2e396bf089f
parentReally only consider latest version in ~arch. (diff)
downloadarch-tools-19044e7c148d10a58c47476582925fbab10b574b.tar.gz
arch-tools-19044e7c148d10a58c47476582925fbab10b574b.tar.bz2
arch-tools-19044e7c148d10a58c47476582925fbab10b574b.zip
Check KEYWORDS for all requested arches.
-rwxr-xr-xstabilization-candidates.py9
1 files changed, 9 insertions, 0 deletions
diff --git a/stabilization-candidates.py b/stabilization-candidates.py
index d2e539c..44cbe75 100755
--- a/stabilization-candidates.py
+++ b/stabilization-candidates.py
@@ -102,6 +102,15 @@ if __name__ == "__main__":
if now - changelog_date < datetime.timedelta(days=options.days):
continue
+ keywords = portage.db["/"]["porttree"].dbapi.aux_get(best_candidate, ['KEYWORDS'])[0]
+ missing_arch = False
+ for arch in options.arch:
+ if arch not in keywords:
+ missing_arch = True
+ break
+ if missing_arch:
+ continue
+
cvs_path = os.path.join(options.repo, cp)
ebuild_name = portage.versions.catsplit(best_candidate)[1] + ".ebuild"
ebuild_path = os.path.join(cvs_path, ebuild_name)