aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2013-01-19 11:36:47 +0000
committerRalph Sennhauser <sera@gentoo.org>2013-01-19 11:36:47 +0000
commitbf1642030e903bde9774829e33d99a36a34bd992 (patch)
treeb11972c008f96d9a5752182cc09552f1e5bd49b9
parentAdd missing symlink-tool appletviewer. (diff)
downloadbaselayout-java-bf1642030e903bde9774829e33d99a36a34bd992.tar.gz
baselayout-java-bf1642030e903bde9774829e33d99a36a34bd992.tar.bz2
baselayout-java-bf1642030e903bde9774829e33d99a36a34bd992.zip
Remove run-java-tool, new home will be eselect-java
svn path=/projects/baselayout-java/trunk/; revision=9151
-rw-r--r--Makefile.am55
-rw-r--r--configure.ac7
-rw-r--r--src/run-java-tool50
3 files changed, 2 insertions, 110 deletions
diff --git a/Makefile.am b/Makefile.am
index 2074f7c..f6c9eb0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,3 @@
-dist_bin_SCRIPTS = \
- src/run-java-tool
-
icondir = $(datadir)/icons/hicolor/48x48/mimetypes
dist_icon_DATA = \
icons/application-x-java-jnlp-file.png
@@ -39,58 +36,6 @@ MAINTAINERCLEANFILES = \
Makefile.in \
INSTALL
-#------------------------------------------------------------------------------
-# FIXME let eselect java-vm handle symlinks.
-tools = \
- appletviewer \
- apt \
- ControlPanel \
- extcheck \
- HtmlConverter \
- idlj \
- jar \
- jarsigner \
- java \
- javac \
- javadoc \
- javah \
- javap \
- javaws \
- jconsole \
- jcontrol \
- jdb \
- jhat \
- jinfo \
- jmap \
- jps \
- jrunscript \
- jsadebugd \
- jstack \
- jstat \
- jstatd \
- jvisualvm \
- keytool \
- native2ascii \
- orbd \
- pack200 \
- policytool \
- rmic \
- rmid \
- rmiregistry \
- schemagen \
- serialver \
- servertool \
- tnameserv \
- wsgen \
- wsimport \
- xjc
-
-.PHONY: $(tools)
-
-$(tools):
- $(LN_S) run-java-tool "$(DESTDIR)/$(bindir)/$@"
-
-install-exec-hook: $(tools)
dist-hook:
if test -d "$(srcdir)"/.svn ; then \
diff --git a/configure.ac b/configure.ac
index e7c8fcb..5f2c456 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,10 +1,7 @@
AC_INIT([baselayout-java],[0.1.0],[java@gentoo.org],[baselayout-java],[https://bugs.gentoo.org/])
AC_PREREQ([2.68])
-AC_CONFIG_SRCDIR([src/run-java-tool])
-AM_INIT_AUTOMAKE([1.11 subdir-objects])
-
-AC_PROG_LN_S
-AC_PROG_SED
+AC_CONFIG_SRCDIR([src/java-config-2.sh])
+AM_INIT_AUTOMAKE([1.11])
AC_CONFIG_FILES([Makefile])
diff --git a/src/run-java-tool b/src/run-java-tool
deleted file mode 100644
index 46f804b..0000000
--- a/src/run-java-tool
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/bin/bash
-
-user_vm="${HOME}/.gentoo/java-config-2/current-user-vm"
-system_vm="/etc/java-config-2/current-system-vm"
-# Try GENTOO_VM
-if [[ -n ${GENTOO_VM} ]]; then
- vmpath="/usr/lib/jvm/${GENTOO_VM}/"
-# Then user VM
-elif [[ -h ${user_vm} ]]; then
- vmpath=$(readlink ${user_vm})
-# And fall back to the system VM
-else
- vmpath=$(readlink ${system_vm})
-fi
-tool=$(basename $0)
-bin=${vmpath}/bin/${tool}
-jrebin=${vmpath}/jre/bin/${tool}
-
-vm_handle=$(basename ${vmpath})
-if [[ -x ${bin} ]]; then
- exec ${bin} "${@}"
-elif [[ -x ${jrebin} ]]; then
- exec ${jrebin} "${@}"
-else
- if [[ ! -d ${vmpath} ]]; then
- echo "* Home for VM '${vm_handle}' does not exist: ${vmpath}" >&2
- if [[ -n ${GENTOO_VM} ]]; then
- echo "* Invalid value for GENTOO_VM: ${GENTOO_VM}"
- elif [[ -h ${user_vm} ]]; then
- echo "* Invalid User VM: ${vm_handle}" >&2
- else
- echo "* Invalid System VM: ${vm_handle}" >&2
- fi
- else
- if [[ ${tool} = "run-java-tool" ]]; then
- echo "* run-java-tool was invoked directly" >&2
- echo "* run-java-tool should only be used via symlinks to it" >&2
- else
- echo "* ${tool} is not available for ${vm_handle} on $(uname -m)" >&2
- echo "* IMPORTANT: some Java tools are not available on some VMs on some architectures" >&2
- if (( ${EUID} != 0 )) && [[ "${DISPLAY}" ]] && type -p notify-send > /dev/null; then
- notify-send -i java-icon48 "Gentoo Java Launcher" "<b>${tool}</b> is not available for ${vm_handle}
-<a href=\"http://www.gentoo.org/doc/en/java.xml\">Gentoo Java User Guide</a>"
- fi
- fi
- fi
- exit 1
-fi
-
-