summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2015-10-19 20:43:03 +0200
committerSebastian Pipping <sebastian@pipping.org>2015-10-19 20:44:18 +0200
commitdfc52015ad657e493d3377cc9a301137a357738f (patch)
tree082f4db854d54b6645d62fc02a7f2ef41b3fcdd7
parentUpdate remote-ids (diff)
downloadbetagarden-dfc52015ad657e493d3377cc9a301137a357738f.tar.gz
betagarden-dfc52015ad657e493d3377cc9a301137a357738f.tar.bz2
betagarden-dfc52015ad657e493d3377cc9a301137a357738f.zip
x11-libs/smooth: 0.8.71.3
-rw-r--r--x11-libs/smooth/Manifest1
-rw-r--r--x11-libs/smooth/files/smooth-0.8.71.3-compile-flags.patch56
-rw-r--r--x11-libs/smooth/files/smooth-0.8.71.3-destdir.patch67
-rw-r--r--x11-libs/smooth/files/smooth-0.8.71.3-ldconfig.patch33
-rw-r--r--x11-libs/smooth/files/smooth-0.8.71.3-no-uninstall.patch25
-rw-r--r--x11-libs/smooth/metadata.xml8
-rw-r--r--x11-libs/smooth/smooth-0.8.71.3.ebuild58
7 files changed, 248 insertions, 0 deletions
diff --git a/x11-libs/smooth/Manifest b/x11-libs/smooth/Manifest
new file mode 100644
index 0000000..8a3fc7e
--- /dev/null
+++ b/x11-libs/smooth/Manifest
@@ -0,0 +1 @@
+DIST smooth-0.8.71.3.zip 7023858 SHA256 f4c023107c61f1efa7e24350b6af5fbdc24fb3c37efd1ea0be319abb116b87aa SHA512 ece8d4721b846a99c9f607c41ad22e3133a2e6559c1e4b7d17698cb3b2a59138b83d7e6d93bce7836434c7b925a6cb93a37d6e9383b24659fafd75e72efa1eb6 WHIRLPOOL 317ae1b9570d3e169b9a8597be3b33d53c102d6e69088df3cc19e96474e678b52fac86a7342d0767ae8e7ce01c2dfccd308d367c3aca17d0a4cf736e2b890b10
diff --git a/x11-libs/smooth/files/smooth-0.8.71.3-compile-flags.patch b/x11-libs/smooth/files/smooth-0.8.71.3-compile-flags.patch
new file mode 100644
index 0000000..e77199f
--- /dev/null
+++ b/x11-libs/smooth/files/smooth-0.8.71.3-compile-flags.patch
@@ -0,0 +1,56 @@
+From 46c5bfb6e1947c0f286f8ca56d804ace58369c6a Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 19 Oct 2015 19:10:54 +0200
+Subject: [PATCH 1/4] Remove optimization and architecture build flags
+
+---
+ Makefile-commands | 21 +--------------------
+ 1 file changed, 1 insertion(+), 20 deletions(-)
+
+diff --git a/Makefile-commands b/Makefile-commands
+index dbd4557..25194c1 100644
+--- a/Makefile-commands
++++ b/Makefile-commands
+@@ -3,16 +3,12 @@
+ include $(SMOOTH_PATH)/Makefile-options
+
+ CC = gcc
+-CCOPTS = -g0 -march=i586 -Wall -I$(SMOOTH_PATH)/include -DUNICODE -D_UNICODE $(MYCCOPTS)
++CCOPTS = -Wall -I$(SMOOTH_PATH)/include -DUNICODE -D_UNICODE $(MYCCOPTS)
+ RC = windres
+ RCOPTS = -DSMOOTH_DLL -O coff
+ LD = gcc
+ LDOPTS = -L$(SMOOTH_PATH)/$(LIBDIR) -lstdc++ -s $(LIBS)
+
+-ifneq ($(BUILD_SOLARIS),True)
+- CCOPTS += -Os
+-endif
+-
+ ifndef GLOBALDLL
+ ifeq ($(BUILD_WIN32),True)
+ LDOPTS += -lsmooth
+@@ -69,21 +65,6 @@ ifneq ($(EXCEPTION),True)
+ CCOPTS += -fno-exceptions
+ endif
+
+-ifeq ($(BUILD_OSX),True)
+- CCOPTS += -arch x86_64 -arch i386
+- LDOPTS += -arch x86_64 -arch i386
+-else ifeq ($(BUILD_X86_64),True)
+- CCOPTS += -m64
+- LDOPTS += -m64
+-
+- RCOPTS += --target=pe-x86-64
+-else
+- CCOPTS += -m32
+- LDOPTS += -m32
+-
+- RCOPTS += --target=pe-i386
+-endif
+-
+ ifndef GLOBALLIB
+ ifndef GLOBALEXE
+ ifndef GLOBALDLL
+--
+2.6.2
+
diff --git a/x11-libs/smooth/files/smooth-0.8.71.3-destdir.patch b/x11-libs/smooth/files/smooth-0.8.71.3-destdir.patch
new file mode 100644
index 0000000..b4e401b
--- /dev/null
+++ b/x11-libs/smooth/files/smooth-0.8.71.3-destdir.patch
@@ -0,0 +1,67 @@
+From 268f6080f5a01e399bd80ebac4195880bf9e1791 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 19 Oct 2015 19:25:46 +0200
+Subject: [PATCH 3/4] Add DESTDIR support
+
+---
+ Makefile | 34 +++++++++++++++++-----------------
+ 1 file changed, 17 insertions(+), 17 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ffba29f..8278a51 100644
+--- a/Makefile
++++ b/Makefile
+@@ -115,14 +115,14 @@ libs:
+ install:
+ ifneq ($(BUILD_WIN32),True)
+ ifneq ($(BUILD_OSX),True)
+- $(MKDIR) -p $(PREFIX)/$(LIB)
+- $(COPY) $(LIBDIR)/libsmooth-$(VERSION)$(SHARED) $(PREFIX)/$(LIB)/libsmooth-$(VERSION)$(SHARED).$(REVISION)
+- $(LINK) -s $(PREFIX)/$(LIB)/libsmooth-$(VERSION)$(SHARED).$(REVISION) $(PREFIX)/$(LIB)/libsmooth-$(VERSION)$(SHARED)
+- $(CHMOD) a=r,u=rw $(PREFIX)/$(LIB)/libsmooth-$(VERSION)$(SHARED).$(REVISION) $(PREFIX)/$(LIB)/libsmooth-$(VERSION)$(SHARED)
++ $(MKDIR) -p $(DESTDIR)$(PREFIX)/$(LIB)
++ $(COPY) $(LIBDIR)/libsmooth-$(VERSION)$(SHARED) $(DESTDIR)$(PREFIX)/$(LIB)/libsmooth-$(VERSION)$(SHARED).$(REVISION)
++ $(LINK) -s libsmooth-$(VERSION)$(SHARED).$(REVISION) $(DESTDIR)$(PREFIX)/$(LIB)/libsmooth-$(VERSION)$(SHARED)
++ $(CHMOD) a=r,u=rw $(DESTDIR)$(PREFIX)/$(LIB)/libsmooth-$(VERSION)$(SHARED).$(REVISION) $(DESTDIR)$(PREFIX)/$(LIB)/libsmooth-$(VERSION)$(SHARED)
+
+- $(COPY) $(LIBDIR)/libsmooth-js-$(VERSION)$(SHARED) $(PREFIX)/$(LIB)/libsmooth-js-$(VERSION)$(SHARED).$(REVISION)
+- $(LINK) -s $(PREFIX)/$(LIB)/libsmooth-js-$(VERSION)$(SHARED).$(REVISION) $(PREFIX)/$(LIB)/libsmooth-js-$(VERSION)$(SHARED)
+- $(CHMOD) a=r,u=rw $(PREFIX)/$(LIB)/libsmooth-js-$(VERSION)$(SHARED).$(REVISION) $(PREFIX)/$(LIB)/libsmooth-js-$(VERSION)$(SHARED)
++ $(COPY) $(LIBDIR)/libsmooth-js-$(VERSION)$(SHARED) $(DESTDIR)$(PREFIX)/$(LIB)/libsmooth-js-$(VERSION)$(SHARED).$(REVISION)
++ $(LINK) -s libsmooth-js-$(VERSION)$(SHARED).$(REVISION) $(DESTDIR)$(PREFIX)/$(LIB)/libsmooth-js-$(VERSION)$(SHARED)
++ $(CHMOD) a=r,u=rw $(DESTDIR)$(PREFIX)/$(LIB)/libsmooth-js-$(VERSION)$(SHARED).$(REVISION) $(DESTDIR)$(PREFIX)/$(LIB)/libsmooth-js-$(VERSION)$(SHARED)
+
+ ifeq ($(BUILD_LINUX),True)
+ ldconfig
+@@ -144,18 +144,18 @@ else
+ $(CHMOD) a=r,u=rw $(PREFIX)/$(LIB)/libsmooth-js-$(VERSION).$(REVISION)$(SHARED) $(PREFIX)/$(LIB)/libsmooth-js-$(VERSION)$(SHARED)
+ endif
+
+- $(MKDIR) -p $(PREFIX)/bin
+- $(COPY) $(BINDIR)/translator $(PREFIX)/bin
+- $(CHMOD) -R a=rX,u=rwX $(PREFIX)/bin/translator
++ $(MKDIR) -p $(DESTDIR)$(PREFIX)/bin
++ $(COPY) $(BINDIR)/translator $(DESTDIR)$(PREFIX)/bin
++ $(CHMOD) -R a=rX,u=rwX $(DESTDIR)$(PREFIX)/bin/translator
+
+- $(MKDIR) -p $(PREFIX)/include
+- $(COPY) -r include/smooth $(PREFIX)/include
+- $(COPY) -r include/smooth-js $(PREFIX)/include
+- $(COPY) include/smooth.h $(PREFIX)/include
++ $(MKDIR) -p $(DESTDIR)$(PREFIX)/include
++ $(COPY) -r include/smooth $(DESTDIR)$(PREFIX)/include
++ $(COPY) -r include/smooth-js $(DESTDIR)$(PREFIX)/include
++ $(COPY) include/smooth.h $(DESTDIR)$(PREFIX)/include
+
+- $(CHMOD) -R a=rX,u=rwX $(PREFIX)/include/smooth
+- $(CHMOD) -R a=rX,u=rwX $(PREFIX)/include/smooth-js
+- $(CHMOD) a=r,u=rw $(PREFIX)/include/smooth.h
++ $(CHMOD) -R a=rX,u=rwX $(DESTDIR)$(PREFIX)/include/smooth
++ $(CHMOD) -R a=rX,u=rwX $(DESTDIR)$(PREFIX)/include/smooth-js
++ $(CHMOD) a=r,u=rw $(DESTDIR)$(PREFIX)/include/smooth.h
+ endif
+
+ uninstall:
+--
+2.6.2
+
diff --git a/x11-libs/smooth/files/smooth-0.8.71.3-ldconfig.patch b/x11-libs/smooth/files/smooth-0.8.71.3-ldconfig.patch
new file mode 100644
index 0000000..3c29254
--- /dev/null
+++ b/x11-libs/smooth/files/smooth-0.8.71.3-ldconfig.patch
@@ -0,0 +1,33 @@
+From 9dd0571500b6876fb69531b57bfa2694efee502e Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 19 Oct 2015 19:26:09 +0200
+Subject: [PATCH 4/4] Stop calling ldconfig
+
+---
+ Makefile | 10 ----------
+ 1 file changed, 10 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 8278a51..1f2c44f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -123,16 +123,6 @@ ifneq ($(BUILD_OSX),True)
+ $(COPY) $(LIBDIR)/libsmooth-js-$(VERSION)$(SHARED) $(DESTDIR)$(PREFIX)/$(LIB)/libsmooth-js-$(VERSION)$(SHARED).$(REVISION)
+ $(LINK) -s libsmooth-js-$(VERSION)$(SHARED).$(REVISION) $(DESTDIR)$(PREFIX)/$(LIB)/libsmooth-js-$(VERSION)$(SHARED)
+ $(CHMOD) a=r,u=rw $(DESTDIR)$(PREFIX)/$(LIB)/libsmooth-js-$(VERSION)$(SHARED).$(REVISION) $(DESTDIR)$(PREFIX)/$(LIB)/libsmooth-js-$(VERSION)$(SHARED)
+-
+-ifeq ($(BUILD_LINUX),True)
+- ldconfig
+-else ifeq ($(BUILD_GNU),True)
+- ldconfig
+-else ifeq ($(BUILD_FREEBSD),True)
+- ldconfig
+-else ifeq ($(BUILD_NETBSD),True)
+- ldconfig
+-endif
+ else
+ $(MKDIR) -p $(PREFIX)/$(LIB)
+ $(COPY) $(DLLNAME) $(PREFIX)/$(LIB)/libsmooth-$(VERSION).$(REVISION)$(SHARED)
+--
+2.6.2
+
diff --git a/x11-libs/smooth/files/smooth-0.8.71.3-no-uninstall.patch b/x11-libs/smooth/files/smooth-0.8.71.3-no-uninstall.patch
new file mode 100644
index 0000000..b4fac3f
--- /dev/null
+++ b/x11-libs/smooth/files/smooth-0.8.71.3-no-uninstall.patch
@@ -0,0 +1,25 @@
+From 8663088e1cdcf76c902b7cdc5eb1f24689dda293 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 19 Oct 2015 19:17:30 +0200
+Subject: [PATCH 2/4] Do not uninstall before install
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index f685a9c..ffba29f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -112,7 +112,7 @@ programs: $(DLLNAME)
+ libs:
+ $(MAKE) -C libraries
+
+-install: uninstall
++install:
+ ifneq ($(BUILD_WIN32),True)
+ ifneq ($(BUILD_OSX),True)
+ $(MKDIR) -p $(PREFIX)/$(LIB)
+--
+2.6.2
+
diff --git a/x11-libs/smooth/metadata.xml b/x11-libs/smooth/metadata.xml
new file mode 100644
index 0000000..16bcc9f
--- /dev/null
+++ b/x11-libs/smooth/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-libs/smooth/smooth-0.8.71.3.ebuild b/x11-libs/smooth/smooth-0.8.71.3.ebuild
new file mode 100644
index 0000000..eca4d0a
--- /dev/null
+++ b/x11-libs/smooth/smooth-0.8.71.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="smooth Class Library"
+HOMEPAGE="http://www.smooth-project.org/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.zip"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/atk
+ dev-libs/fribidi
+ dev-libs/glib:*
+ dev-libs/libxml2
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libpng:*
+ sys-devel/gcc:*[cxx]
+ sys-libs/zlib
+ virtual/jpeg:*
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/pango
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog ToDo.xml )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-compile-flags.patch
+ epatch "${FILESDIR}"/${P}-destdir.patch
+ epatch "${FILESDIR}"/${P}-ldconfig.patch
+ epatch "${FILESDIR}"/${P}-no-uninstall.patch
+}
+
+src_compile() {
+ emake
+ emake -C tools/translator
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ insinto /usr/share/${PF}/
+ doins -r doc samples tutorial
+}