summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/dit/dit-9999.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/app-editors/dit/dit-9999.ebuild b/app-editors/dit/dit-9999.ebuild
index 89badc9..f917328 100644
--- a/app-editors/dit/dit-9999.ebuild
+++ b/app-editors/dit/dit-9999.ebuild
@@ -1,26 +1,23 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
+EAPI=7
-inherit subversion
+inherit git-r3
DESCRIPTION="ncurses-based text editor for Unix systems"
HOMEPAGE="http://dit-editor.sourceforge.net/"
-ESVN_REPO_URI="https://dit-editor.svn.sourceforge.net/svnroot/dit-editor/trunk"
+EGIT_REPO_URI="https://github.com/hishamhm/dit.git"
LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="0"
KEYWORDS=""
IUSE=""
-DEPEND="dev-lang/lua"
+DEPEND="dev-lang/lua:5.3"
RDEPEND="${DEPEND}"
src_prepare() {
+ eapply_user
./autogen.sh || die
}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-}