aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-10-02 23:06:28 +0000
committerMike Gilbert <floppym@gentoo.org>2012-10-02 23:06:28 +0000
commitaf6a32c3198ddb11847488eece68400d532f3830 (patch)
treee1d757e5825b09a126657cab24a432a529f848dd
parentadd locking to /etc/xml dir to avoid multiple runs trashing each other (diff)
downloadbuild-docbook-catalog-af6a32c3198ddb11847488eece68400d532f3830.tar.gz
build-docbook-catalog-af6a32c3198ddb11847488eece68400d532f3830.tar.bz2
build-docbook-catalog-af6a32c3198ddb11847488eece68400d532f3830.zip
Don't install /etc/xml/.keep. Bug 437004.v1.19.1
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index c33b7cd..0895db0 100644
--- a/Makefile
+++ b/Makefile
@@ -10,15 +10,14 @@ PREFIX = /usr
SBINDIR = $(PREFIX)/sbin
install:
- mkdir -p $(DESTDIR)$(CONFDIR) $(DESTDIR)$(SBINDIR)
- touch $(DESTDIR)$(CONFDIR)/.keep
+ install -d $(DESTDIR)$(SBINDIR)
install -m 755 build-docbook-catalog $(DESTDIR)$(SBINDIR)
dist:
rm -rf $(P)
mkdir -p $(P)
cp -pPR build-docbook-catalog Makefile README $(P)/
- tar cf - $(P) | xz -9 > $(P).tar.xz
+ tar --posix --owner 0 --group 0 -cf - $(P) | xz -9 > $(P).tar.xz
rm -rf $(P)
.PHONY: all clean dist install