aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-10-02 23:57:53 -0400
committerMike Frysinger <vapier@gentoo.org>2021-10-02 23:57:53 -0400
commitbd29656622f75011e723c71880ebba5844f7f518 (patch)
tree9ffd1a91516b01b53ad149f70bf8f0128a739bf9
parentmake file updates atomic (diff)
downloadbuild-docbook-catalog-bd29656622f75011e723c71880ebba5844f7f518.tar.gz
build-docbook-catalog-bd29656622f75011e723c71880ebba5844f7f518.tar.bz2
build-docbook-catalog-bd29656622f75011e723c71880ebba5844f7f518.zip
update README & dist processv2.0
Now that we're in git, we can simplify things a lot. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
-rw-r--r--Makefile14
-rw-r--r--README29
-rwxr-xr-xbuild-docbook-catalog9
3 files changed, 9 insertions, 43 deletions
diff --git a/Makefile b/Makefile
index b920de3..cb8634a 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,5 @@
-PN = build-docbook-catalog
-PV = $(shell awk '/^\# .Header:/{print $$4;exit}' build-docbook-catalog)
-P = $(PN)-$(PV)
+# Copyright 2004-2021 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
all:
@@ -14,11 +13,4 @@ install:
install -d $(DESTDIR)$(SBINDIR)
install -m 755 build-docbook-catalog $(DESTDIR)$(SBINDIR)
-dist:
- rm -rf $(P)
- mkdir -p $(P)
- cp -pPR build-docbook-catalog Makefile README $(P)/
- tar --posix --owner 0 --group 0 -cf - $(P) | xz -9 > $(P).tar.xz
- rm -rf $(P)
-
-.PHONY: all clean dist install
+.PHONY: all clean install
diff --git a/README b/README
index 8c3716d..8e1e345 100644
--- a/README
+++ b/README
@@ -1,31 +1,10 @@
-$Header: /usr/local/src/gentoo/gentoo-src/cvsroot/gentoo-src/build-docbook-catalog/README,v 1.2 2012/03/27 22:36:51 vapier Exp $
-
This is the source for app-text/build-docbook-catalog, which is a
script to regenerate the xml docbook catalog.
You can find it here:
- http://sources.gentoo.org/gentoo-src/build-docbook-catalog/
-
-To make a release of this script, do the following:
-
-1. Commit your changes, create the tarball, and post it:
-
- make dist
- cp build-docbook-catalog-*.tar.xz /usr/portage/distfiles/
- scp build-docbook-catalog-*.tar.xz dev.gentoo.org:/space/distfiles-local/
-
-2. Make a new version of the build-docbook-catalog ebuild:
-
- ego build-docbook-catalog
- cp $(ls -t1 *.ebuild | head -n 1) build-docbook-catalog-${rev}.ebuild
- ekeyword ~all build-docbook-catalog-${rev}.ebuild
-
-3. Do the normal steps to generate a digest, mark the previous version
- stable, use echangelog to add a ChangeLog entry, etc.
+ https://gitweb.gentoo.org/proj/build-docbook-catalog.git/
- cvs add build-docbook-catalog-${rev}.ebuild
- ebuild build-docbook-catalog-${rev}.ebuild digest
- echangelog
- repoman commit -m "version bump to ${rev}"
+To make a release of this script, create a new git tag.
+ git tag v2.0
-vim:sw=4 expandtab
+We pull tarballs from the git site now. So update the ebuild like normal.
diff --git a/build-docbook-catalog b/build-docbook-catalog
index b420541..9064d72 100755
--- a/build-docbook-catalog
+++ b/build-docbook-catalog
@@ -1,13 +1,7 @@
#!/bin/bash
-# $Header: /usr/local/src/gentoo/gentoo-src/cvsroot/gentoo-src/build-docbook-catalog/build-docbook-catalog,v 1.21 2016/05/23 15:53:13 haubi Exp $
-#
-# build-docbook-catalog: populate /etc/xml/docbook based in
-# installed docbook-xml-dtd versions.
-#
-# Copyright 2004-2012 Gentoo Foundation
+# Copyright 2004-2021 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# written by Aron Griffis
-#
EPREFIX=
ROOTCONFDIR="${EPREFIX}"/etc/xml
@@ -28,6 +22,7 @@ GETOPT=getopt
usage() {
cat <<-EOF
Usage: ${ZERO} [options]
+ Regenerate the XML docbook catalog under ${ROOTCONFDIR}.
Options:
-r, --root ROOT path to work on