aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index c33b7cd..0895db0 100644
--- a/Makefile
+++ b/Makefile
@@ -10,15 +10,14 @@ PREFIX = /usr
SBINDIR = $(PREFIX)/sbin
install:
- mkdir -p $(DESTDIR)$(CONFDIR) $(DESTDIR)$(SBINDIR)
- touch $(DESTDIR)$(CONFDIR)/.keep
+ install -d $(DESTDIR)$(SBINDIR)
install -m 755 build-docbook-catalog $(DESTDIR)$(SBINDIR)
dist:
rm -rf $(P)
mkdir -p $(P)
cp -pPR build-docbook-catalog Makefile README $(P)/
- tar cf - $(P) | xz -9 > $(P).tar.xz
+ tar --posix --owner 0 --group 0 -cf - $(P) | xz -9 > $(P).tar.xz
rm -rf $(P)
.PHONY: all clean dist install