aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheofilos Intzoglou <int.teo@gmail.com>2011-10-06 19:54:15 +0300
committerTheofilos Intzoglou <int.teo@gmail.com>2011-10-06 19:54:15 +0300
commit968c1d93406b8a73bff668e44073dad37ef4f8ac (patch)
tree3f6e9e81f45cd16fdbb242f18b429792a91ecf4e
parentForgot to tell cmake to install the library! (diff)
downloadc-portage-968c1d93406b8a73bff668e44073dad37ef4f8ac.tar.gz
c-portage-968c1d93406b8a73bff668e44073dad37ef4f8ac.tar.bz2
c-portage-968c1d93406b8a73bff668e44073dad37ef4f8ac.zip
Add rules to install the cpp-portage library and its corresponding header files
-rw-r--r--src/Qt/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Qt/CMakeLists.txt b/src/Qt/CMakeLists.txt
index 2b11759..1b639ec 100644
--- a/src/Qt/CMakeLists.txt
+++ b/src/Qt/CMakeLists.txt
@@ -8,3 +8,6 @@ set(cpp-portage_HDRS qportagesettings.h)
QT4_WRAP_CPP(cpp-portage_MOC_SRCS ${cpp-portage_HDRS})
add_library(cpp-portage qportagesettings.cpp ${cpp-portage_MOC_SRCS})
+install(TARGETS cpp-portage DESTINATION lib)
+install(DIRECTORY . DESTINATION include/cpp-portage
+ FILES_MATCHING PATTERN "*.h") \ No newline at end of file