aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3fb5b8b..472f2a9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -4,8 +4,8 @@ include_directories(${PYTHON_INCLUDE_DIRS})
link_directories(${PYTHON_LIBRARIES})
add_definitions(-std=c99)
-set(c-portage_SRCS dataconnect.c dict.c flag.c interpreter.c packageproperties.c stringlist.c)
-set(c-portage_HDRS dataconnect.h dict.h flag.h internal.h interpreter.h packageproperties.h stringlist.h)
+set(c-portage_SRCS dataconnect.c dict.c flag.c interpreter.c packageproperties.c portagesettings.c stringlist.c)
+set(c-portage_HDRS dataconnect.h dict.h flag.h internal.h interpreter.h packageproperties.h portage.h portagesettings.h stringlist.h)
add_library(c-portage SHARED ${c-portage_SRCS})
target_link_libraries(c-portage ${PYTHON_LIBRARY})
@@ -15,8 +15,6 @@ target_link_libraries(tester c-portage)
install(TARGETS c-portage DESTINATION lib)
install(FILES ${c-portage_HDRS} DESTINATION include/c-portage)
-option(CppPortage "Enable c++ wrapper for c-portage (uses Qt4)")
-
-if (CppPortage)
+if (Qt4)
add_subdirectory(Qt)
-endif(CppPortage)
+endif(Qt4)