aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2023-01-04 12:20:15 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2023-01-04 12:22:23 -0800
commitb7c01cee3991c6fa750632492ad7c277474940be (patch)
tree5c1dfdd913c1e40858764d89d99a325d07d165db
parentsrc/base.tera: update template again (diff)
downloadcargo-ebuild-b7c01cee3991c6fa750632492ad7c277474940be.tar.gz
cargo-ebuild-b7c01cee3991c6fa750632492ad7c277474940be.tar.bz2
cargo-ebuild-b7c01cee3991c6fa750632492ad7c277474940be.zip
README.md: update
Closes: https://github.com/gentoo/cargo-ebuild/pull/25 Closes: https://github.com/gentoo/cargo-ebuild/pull/31 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--README.md193
1 files changed, 144 insertions, 49 deletions
diff --git a/README.md b/README.md
index d3ee183..c187b75 100644
--- a/README.md
+++ b/README.md
@@ -1,7 +1,6 @@
# cargo-ebuild
[![Build Status](https://github.com/gentoo/cargo-ebuild/actions/workflows/rust.yml/badge.svg)](https://github.com/gentoo/cargo-ebuild/actions)
-[![Rust version]( https://img.shields.io/badge/rust-1.26-blue.svg)]()
[![Latest Version](https://img.shields.io/crates/v/cargo-ebuild.svg)](https://crates.io/crates/cargo-ebuild)
[![All downloads](https://img.shields.io/crates/d/cargo-ebuild.svg)](https://crates.io/crates/cargo-ebuild)
[![Downloads of latest version](https://img.shields.io/crates/dv/cargo-ebuild.svg)](https://crates.io/crates/cargo-ebuild)
@@ -31,57 +30,149 @@ ebuild for that crate.
### Example
-```bash
-$ git clone https://github.com/cardoe/cargo-ebuild.git
+```shell-session
+$ git clone https://github.com/gentoo/cargo-ebuild.git
$ cd cargo-ebuild
-$ git checkout v0.3.0
+$ git checkout 0.5.3
$ cargo ebuild
-$ cat cargo-ebuild-0.3.0.ebuild
+$ cat cargo-ebuild-0.5.3.ebuild
```
-```ebuild
-# Copyright 2017-2020 Gentoo Authors
+```bash
+# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# Auto-Generated by cargo-ebuild 0.3.0
+# Auto-Generated by cargo-ebuild 0.5.3
-EAPI=7
+EAPI=8
CRATES="
-ansi_term-0.11.0
-anyhow-1.0.26
-atty-0.2.13
-bitflags-1.2.0
-cargo_metadata-0.9.1
-clap-2.33.0
-either-1.5.3
-heck-0.3.1
-itertools-0.8.2
-itoa-0.4.4
-libc-0.2.62
-proc-macro-error-0.2.6
-proc-macro2-1.0.5
-quote-1.0.2
-redox_syscall-0.1.56
-ryu-1.0.0
-semver-0.9.0
-semver-parser-0.7.0
-serde-1.0.101
-serde_derive-1.0.101
-serde_json-1.0.41
-strsim-0.8.0
-structopt-0.3.3
-structopt-derive-0.3.3
-syn-1.0.5
-textwrap-0.11.0
-time-0.1.42
-unicode-segmentation-1.3.0
-unicode-width-0.1.6
-unicode-xid-0.2.0
-vec_map-0.8.1
-winapi-0.3.8
-winapi-i686-pc-windows-gnu-0.4.0
-winapi-x86_64-pc-windows-gnu-0.4.0
+ aho-corasick-0.7.20
+ ansi_term-0.12.1
+ anyhow-1.0.68
+ atty-0.2.14
+ autocfg-1.1.0
+ bitflags-1.3.2
+ block-buffer-0.10.3
+ bstr-0.2.17
+ camino-1.1.1
+ cargo-lock-8.0.3
+ cargo-platform-0.1.2
+ cargo_metadata-0.15.2
+ cc-1.0.78
+ cfg-if-1.0.0
+ clap-2.34.0
+ cpufeatures-0.2.5
+ crates-index-0.18.11
+ crossbeam-channel-0.5.6
+ crossbeam-deque-0.8.2
+ crossbeam-epoch-0.9.13
+ crossbeam-utils-0.8.14
+ crypto-common-0.1.6
+ cvss-2.0.0
+ digest-0.10.6
+ either-1.8.0
+ fnv-1.0.7
+ form_urlencoded-1.1.0
+ fs-err-2.9.0
+ generic-array-0.14.6
+ git2-0.15.0
+ globset-0.4.9
+ globwalk-0.8.1
+ heck-0.3.3
+ hermit-abi-0.1.19
+ hermit-abi-0.2.6
+ hex-0.4.3
+ home-0.5.4
+ humantime-2.1.0
+ humantime-serde-1.1.1
+ idna-0.3.0
+ ignore-0.4.18
+ itertools-0.10.5
+ itoa-1.0.5
+ jobserver-0.1.25
+ lazy_static-1.4.0
+ libc-0.2.139
+ libgit2-sys-0.14.0+1.5.0
+ libssh2-sys-0.2.23
+ libz-sys-1.1.8
+ log-0.4.17
+ memchr-2.5.0
+ memoffset-0.7.1
+ num_cpus-1.15.0
+ once_cell-1.17.0
+ openssl-probe-0.1.5
+ openssl-sys-0.9.80
+ percent-encoding-2.2.0
+ pest-2.5.2
+ pest_derive-2.5.2
+ pest_generator-2.5.2
+ pest_meta-2.5.2
+ phf-0.11.1
+ phf_generator-0.11.1
+ phf_macros-0.11.1
+ phf_shared-0.11.1
+ pkg-config-0.3.26
+ platforms-3.0.2
+ proc-macro-error-1.0.4
+ proc-macro-error-attr-1.0.4
+ proc-macro2-1.0.49
+ quote-1.0.23
+ rand-0.8.5
+ rand_core-0.6.4
+ rayon-1.6.1
+ rayon-core-1.10.1
+ regex-1.7.0
+ regex-syntax-0.6.28
+ rustc-hash-1.1.0
+ rustsec-0.26.4
+ ryu-1.0.12
+ same-file-1.0.6
+ scopeguard-1.1.0
+ semver-1.0.16
+ serde-1.0.152
+ serde_derive-1.0.152
+ serde_json-1.0.91
+ sha1-0.10.5
+ siphasher-0.3.10
+ smartstring-1.0.1
+ static_assertions-1.1.0
+ strsim-0.8.0
+ structopt-0.3.26
+ structopt-derive-0.4.18
+ syn-1.0.107
+ tera-1.17.1
+ textwrap-0.11.0
+ thiserror-1.0.38
+ thiserror-impl-1.0.38
+ thread_local-1.1.4
+ time-0.3.17
+ time-core-0.1.0
+ tinyvec-1.6.0
+ tinyvec_macros-0.1.0
+ toml-0.5.10
+ typenum-1.16.0
+ ucd-trie-0.1.5
+ unic-char-property-0.9.0
+ unic-char-range-0.9.0
+ unic-common-0.9.0
+ unic-segment-0.9.0
+ unic-ucd-segment-0.9.0
+ unic-ucd-version-0.9.0
+ unicode-bidi-0.3.8
+ unicode-ident-1.0.6
+ unicode-normalization-0.1.22
+ unicode-segmentation-1.10.0
+ unicode-width-0.1.10
+ url-2.3.1
+ vcpkg-0.2.15
+ vec_map-0.8.2
+ version_check-0.9.4
+ walkdir-2.3.2
+ winapi-0.3.9
+ winapi-i686-pc-windows-gnu-0.4.0
+ winapi-util-0.1.5
+ winapi-x86_64-pc-windows-gnu-0.4.0
"
inherit cargo
@@ -89,18 +180,22 @@ inherit cargo
DESCRIPTION="Generates an ebuild for a package using the in-tree eclasses."
# Double check the homepage as the cargo_metadata crate
# does not provide this value so instead repository is used
-HOMEPAGE="https://github.com/cardoe/cargo-ebuild"
-SRC_URI="$(cargo_crate_uris ${CRATES})"
-RESTRICT="mirror"
+HOMEPAGE="https://github.com/gentoo/cargo-ebuild"
+SRC_URI="$(cargo_crate_uris)"
+
# License set may be more restrictive as OR is not respected
# use cargo-license for a more accurate license picture
-LICENSE="Apache-2.0 BSL-1.0 MIT"
+LICENSE="Apache-2.0 Boost-1.0 MIT MPL-2.0+ Unicode-DFS-2016 Unlicense ZLIB"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
DEPEND=""
-RDEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+# rust does not use *FLAGS from make.conf, silence portage warning
+# update with proper path to binaries this crate installs, omit leading /
+QA_FLAGS_IGNORED="usr/bin/${PN}"
```
## API