aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2017-12-03 20:34:00 -0600
committerDoug Goldstein <cardoe@cardoe.com>2017-12-03 20:34:00 -0600
commit079963ea3adc9a62e090c59d12aa7ce57d2aec07 (patch)
treec4f12d6d29e4adced951fc10020ab792edf09508 /README.md
parentREADME: expand on the badges (diff)
downloadcargo-ebuild-079963ea3adc9a62e090c59d12aa7ce57d2aec07.tar.gz
cargo-ebuild-079963ea3adc9a62e090c59d12aa7ce57d2aec07.tar.bz2
cargo-ebuild-079963ea3adc9a62e090c59d12aa7ce57d2aec07.zip
README: expand usage instructions
Expanded out the usage instructions to ensure its more clear how to use this crate. fixes #3.
Diffstat (limited to 'README.md')
-rw-r--r--README.md175
1 files changed, 114 insertions, 61 deletions
diff --git a/README.md b/README.md
index 9bf7650..892ee0b 100644
--- a/README.md
+++ b/README.md
@@ -11,81 +11,134 @@
[cargo.eclass](https://gitweb.gentoo.org/repo/gentoo.git/tree/eclass/cargo.eclass)
to build a Cargo based project for [Gentoo](https://gentoo.org/)
+## Installation
+
Install it with Cargo:
```
$ cargo install cargo-ebuild
```
-In its default mode, `cargo ebuild` will write the recipe for the
-local crate:
+## Usage
+
+You will first need to get the sources to the crate you want to install.
+Your best bet is to search for the crate at [crates.io][https://crates.io]
+and follow the *Repository* link. This should give you the ability to clone
+the repo. Once you have cloned the repo, change into the directory and
+ensure that you checkout the tag corresponding to the version you would like
+to package. Lastly you will execute the `cargo ebuild` command to generate the
+ebuild for that crate.
+
+### Example
+```bash
+$ git clone https://github.com/cardoe/cargo-ebuild.git
+$ cd cargo-ebuild
+$ git checkout 0.1.5
+$ cargo ebuild
+$ cat cargo-ebuild-0.1.5.ebuild
```
-# Auto-Generated by cargo-ebuild 0.1.0
+
+```ebuild
+# Copyright 2017-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Auto-Generated by cargo-ebuild 0.1.5
EAPI=6
CRATES="
+advapi32-sys-0.2.0
+aho-corasick-0.6.3
+atty-0.2.3
+backtrace-0.3.3
+backtrace-sys-0.1.16
+bitflags-0.7.0
+bitflags-0.8.2
+cargo-0.21.1
+cargo-ebuild-0.1.5
+cc-1.0.3
+cfg-if-0.1.0
+cmake-0.1.22
+crates-io-0.10.0
+crossbeam-0.2.10
+curl-0.4.6
+curl-sys-0.3.10
+dbghelp-sys-0.2.0
+docopt-0.8.1
+dtoa-0.4.2
+env_logger-0.4.3
+error-chain-0.11.0
+filetime-0.1.10
+flate2-0.2.19
+foreign-types-0.2.0
+fs2-0.4.2
+gcc-0.3.45
gdi32-sys-0.2.0
-rand-0.3.14
-rustache-0.0.3
-libz-sys-1.0.4
-url-0.2.38
-toml-0.1.30
-utf8-ranges-0.1.3
-aho-corasick-0.5.2
-cargo-ebuild-0.1.0
-gcc-0.3.28
-curl-0.2.19
-openssl-sys-0.7.14
-thread-id-2.0.0
-log-0.3.6
-regex-syntax-0.3.4
-tempdir-0.3.4
-memstream-0.0.1
-unicode-bidi-0.2.3
-libgit2-sys-0.4.3
-env_logger-0.3.3
-user32-sys-0.2.0
-cargo-0.10.0
-docopt-0.6.81
-miniz-sys-0.1.7
-curl-sys-0.1.34
-tar-0.4.6
-term-0.4.4
-pkg-config-0.3.8
+git2-0.6.4
+git2-curl-0.7.0
glob-0.2.11
-unicode-normalization-0.1.2
-advapi32-sys-0.1.2
-semver-0.2.3
-cmake-0.1.17
-regex-0.1.73
-crates-io-0.2.0
-memchr-0.1.11
-libressl-pnacl-sys-2.1.6
-matches-0.1.2
-winapi-0.2.7
-libssh2-sys-0.1.37
-uuid-0.1.18
-flate2-0.2.14
-thread_local-0.2.6
-nom-1.2.3
-fs2-0.2.5
-idna-0.1.0
-pnacl-build-helper-1.4.10
-bitflags-0.1.1
-url-1.1.1
-git2-0.4.3
-winapi-build-0.1.1
+hex-0.2.0
+idna-0.1.1
+itoa-0.3.4
+jobserver-0.1.8
kernel32-sys-0.2.2
-num_cpus-0.2.13
-filetime-0.1.10
-crossbeam-0.2.9
-time-0.1.35
-git2-curl-0.4.1
-strsim-0.3.0
-libc-0.2.13
-rustc-serialize-0.3.19
+lazy_static-0.2.8
+libc-0.2.21
+libgit2-sys-0.6.7
+libssh2-sys-0.2.5
+libz-sys-1.0.13
+log-0.3.7
+matches-0.1.4
+memchr-1.0.2
+miniz-sys-0.1.9
+miow-0.2.1
+net2-0.2.27
+num-traits-0.1.40
+num_cpus-1.3.0
+openssl-0.9.11
+openssl-probe-0.1.1
+openssl-sys-0.9.11
+pkg-config-0.3.9
+psapi-sys-0.1.0
+quote-0.3.15
+rand-0.3.15
+redox_syscall-0.1.17
+redox_termios-0.1.1
+regex-0.2.2
+regex-syntax-0.4.1
+rustc-demangle-0.1.5
+scoped-tls-0.1.0
+semver-0.7.0
+semver-parser-0.7.0
+serde-1.0.16
+serde_derive-1.0.16
+serde_derive_internals-0.16.0
+serde_ignored-0.0.3
+serde_json-1.0.5
+shell-escape-0.1.3
+strsim-0.6.0
+syn-0.11.11
+synom-0.11.3
+tar-0.4.11
+tempdir-0.3.5
+termcolor-0.3.3
+termion-1.5.1
+thread_local-0.3.4
+time-0.1.36
+toml-0.4.5
+unicode-bidi-0.2.5
+unicode-normalization-0.1.4
+unicode-xid-0.0.4
+unreachable-1.0.0
+url-1.4.0
+user32-sys-0.2.0
+utf8-ranges-1.0.0
+void-1.0.2
+winapi-0.2.8
+winapi-build-0.1.1
+wincolor-0.1.4
+ws2_32-sys-0.2.1
"
inherit cargo
@@ -94,7 +147,7 @@ DESCRIPTION="Generates an ebuild for a package using the in-tree eclasses."
HOMEPAGE="https://github.com/cardoe/cargo-ebuild"
SRC_URI="$(cargo_crate_uris ${CRATES})"
RESTRICT="mirror"
-LICENSE=""
+LICENSE="MIT/Apache-2.0" # Update to proper Gentoo format
SLOT="0"
KEYWORDS="~amd64"
IUSE=""