aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Thibodeau <kyron@neuralbs.com>2008-07-04 01:18:51 -0400
committerEric Thibodeau <kyron@neuralbs.com>2008-07-04 01:18:51 -0400
commit53218abeb4952627c98c094b963c9049d02a1280 (patch)
tree9faea8f6208262b5816deb87527aec57dace9861
parentNFSroot stage4 + automatic configs and correction on LiveCD(master node) and ... (diff)
downloadclustering-livecd-53218abeb4952627c98c094b963c9049d02a1280.tar.gz
clustering-livecd-53218abeb4952627c98c094b963c9049d02a1280.tar.bz2
clustering-livecd-53218abeb4952627c98c094b963c9049d02a1280.zip
Added quick NFSroot HOWTO
-rw-r--r--NFSroot-HOWTO16
-rw-r--r--catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh5
2 files changed, 21 insertions, 0 deletions
diff --git a/NFSroot-HOWTO b/NFSroot-HOWTO
new file mode 100644
index 0000000..25ea698
--- /dev/null
+++ b/NFSroot-HOWTO
@@ -0,0 +1,16 @@
+# Essentially:
+# 1- set up the environment as described in the LiveCD-HOWTO
+# 2- :
+
+cd /var/git/clustering-livecd/catalyst/nfsroot/2008.0/specs/amd64/
+for I in stage1.spec stage2.spec stage3.spec nfsroot_stage4.spec
+do
+ catalyst -f $I
+done
+
+# Your NFSroot is now in: /var/tmp/catalyst/tmp/default/stage4-amd64-nfsroot-20080629/
+# you can copy it over directly to /tftproot/nfsroot/$(uname -m)/ and start using it
+# if you have such a setup ;)
+
+# of course...there is also the stage4 in:
+# /var/tmp/catalyst/builds/default/stage4-amd64-nfsroot-20080629.tar.bz2
diff --git a/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh b/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh
index 6634564..4ac5cd4 100644
--- a/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh
+++ b/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh
@@ -23,6 +23,11 @@ unionfs_prep()
done
}
+set_runlevel()
+{
+ # maybe something to do here...can't remember...
+ #sed -i -e's:l3:3:wait:/sbin/rc nfsmount::' etc/inittab
+}
kernel_links
unionfs_prep