summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-13 11:44:43 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-13 11:44:43 +0100
commitf0e4de1afc2183db941fc1b65c2af80ceff50021 (patch)
tree8c1ec52be5fe45beea5eb1a6a3379bb76e8ec729
parentcompany-ebuild.el: bump to 0.1.3 (diff)
downloadcompany-ebuild-f0e4de1afc2183db941fc1b65c2af80ceff50021.tar.gz
company-ebuild-f0e4de1afc2183db941fc1b65c2af80ceff50021.tar.bz2
company-ebuild-f0e4de1afc2183db941fc1b65c2af80ceff50021.zip
Makefile: update
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 606ff5d..ecb9ff5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,10 @@
PWD ?= $(shell pwd)
+ELS = $(wildcard $(PWD)/*.el)
+ELCS = $(ELS:.el=.elc)
+
EMACS := emacs
-FIND := find
+FIND := rm -f
EMACFLAGS := --batch -q --no-site-file -L $(PWD)
EMACSCMD = $(EMACS) $(EMACFLAGS)
@@ -10,18 +13,15 @@ EMACSCMD = $(EMACS) $(EMACFLAGS)
.PHONY: all
all: clean compile
-
.PHONY: clean
clean:
- $(FIND) $(PWD) -iname "*.elc" -delete
-
+ $(RM) $(ELCS)
%.elc:
$(EMACSCMD) --eval "(byte-compile-file \"$(*).el\" 0)"
.PHONY: compile
-compile: company-ebuild-custom.elc company-ebuild-keywords.elc company-ebuild.elc
-
+compile: $(ELCS)
.PHONY: install
install: compile