aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Engel <sighunter@gmx.de>2024-08-28 13:13:20 +0200
committerUlrich Müller <ulm@gentoo.org>2024-09-14 21:10:58 +0200
commita166928ab188ff3b108d9a2651217dd96828b282 (patch)
tree9829a6596aab6d66a07061bef0d4b06a77bf4cc6
parentg-c/portage-cache: Refine the allowed variables for conditional inherits (diff)
downloaddevmanual-a166928ab188ff3b108d9a2651217dd96828b282.tar.gz
devmanual-a166928ab188ff3b108d9a2651217dd96828b282.tar.bz2
devmanual-a166928ab188ff3b108d9a2651217dd96828b282.zip
src_unpack/rpm-sources: Replace src_unpack override example code
This replaces the code example with a snippet of how it is currently used in ::gentoo/dev-util/intel-ocl-sdk/intel-ocl-sdk-18.1.0.015.ebuild because the old example code had multiple issues. Signed-off-by: Sebastian Engel <sighunter@gmx.de> Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--ebuild-writing/functions/src_unpack/rpm-sources/text.xml6
1 files changed, 2 insertions, 4 deletions
diff --git a/ebuild-writing/functions/src_unpack/rpm-sources/text.xml b/ebuild-writing/functions/src_unpack/rpm-sources/text.xml
index 0029c53..99c932e 100644
--- a/ebuild-writing/functions/src_unpack/rpm-sources/text.xml
+++ b/ebuild-writing/functions/src_unpack/rpm-sources/text.xml
@@ -25,10 +25,8 @@ manner such as:
<codesample lang="ebuild">
src_unpack() {
- rpm_src_unpack ${A}
- cd "${S}"
-
- use ssl &amp;&amp; eapply "${FILESDIR}/${PV}/${P}-ssl.patch"
+ unpack ${A}
+ rpm_unpack "${S}/rpm/intel-openclrt-${PV}-${ALT_PV}.x86_64.rpm"
}
</codesample>