aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-11 13:12:26 -0800
committerMatt Turner <mattst88@gentoo.org>2022-03-14 10:05:41 -0700
commitc2c0b163b73c53d8aa65ed6403bdf8f116ef45b8 (patch)
treefb8524353e72455b4b840c78ba95f00bdc499230
parentquickstart: make blocker non-pure-DEPEND (diff)
downloaddevmanual-c2c0b163b73c53d8aa65ed6403bdf8f116ef45b8.tar.gz
devmanual-c2c0b163b73c53d8aa65ed6403bdf8f116ef45b8.tar.bz2
devmanual-c2c0b163b73c53d8aa65ed6403bdf8f116ef45b8.zip
Remove references to repoman
Bug: https://bugs.gentoo.org/835013 Closes: https://github.com/gentoo/devmanual/pull/274 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--appendices/common-problems/text.xml2
-rw-r--r--appendices/editor-configuration/emacs/text.xml4
-rw-r--r--ebuild-maintenance/git/text.xml39
-rw-r--r--ebuild-maintenance/new-ebuild/text.xml8
-rw-r--r--ebuild-writing/common-mistakes/text.xml4
-rw-r--r--ebuild-writing/file-format/text.xml6
-rw-r--r--ebuild-writing/misc-files/metadata/text.xml2
-rw-r--r--eclass-writing/text.xml3
-rw-r--r--general-concepts/ebuild-revisions/text.xml5
-rw-r--r--general-concepts/manifest/text.xml7
-rw-r--r--keywording/text.xml12
-rw-r--r--tools-reference/text.xml3
12 files changed, 35 insertions, 60 deletions
diff --git a/appendices/common-problems/text.xml b/appendices/common-problems/text.xml
index 4fcdda4..d124070 100644
--- a/appendices/common-problems/text.xml
+++ b/appendices/common-problems/text.xml
@@ -161,7 +161,7 @@ directories Executable stacks ... binary files whose stack is marked with
</section>
<section>
-<title>Handling <c>repoman</c> Messages</title>
+<title>Handling <c>pkgcheck</c> Messages</title>
<body>
<todo>
diff --git a/appendices/editor-configuration/emacs/text.xml b/appendices/editor-configuration/emacs/text.xml
index f822388..c90dba6 100644
--- a/appendices/editor-configuration/emacs/text.xml
+++ b/appendices/editor-configuration/emacs/text.xml
@@ -50,9 +50,7 @@ automatically before saving the file.
<p>
Other useful settings can be disabled backup files
(by <c>(setq make-backup-files nil)</c>), so you don't clutter the git
-repository
-directories and confuse repoman with it (by adding unnecessary entries
-into a Manifest file e.g.). Emacs can even contact the outside world
+repository directories. Emacs can even contact the outside world
by using the X servers clipboard abilities when yanking, which is
activated by <c>(setq x-select-enable-clipboard t)</c>.
</p>
diff --git a/ebuild-maintenance/git/text.xml b/ebuild-maintenance/git/text.xml
index cf8d6ba..01a4da0 100644
--- a/ebuild-maintenance/git/text.xml
+++ b/ebuild-maintenance/git/text.xml
@@ -112,11 +112,10 @@ the historical commits after the initial git commit.
<body>
<p>
-The recommended way of committing to the Gentoo repository is to use <c>repoman
-commit</c> or <c>pkgdev commit</c> (then <c>pkgdev push</c>). It automatically
-performs the necessary QA checks on the package being committed and has other
-features helping with the Gentoo workflow. However, <c>repoman</c> is currently
-limited to creating a single commit to a single package.
+The recommended way of committing to the Gentoo repository is to use <c>pkgdev
+commit</c> (then <c>pkgdev push</c>). It automatically performs the necessary
+QA checks on the package being committed and has other features helping with
+the Gentoo workflow.
</p>
<p>
@@ -130,21 +129,19 @@ used. The valid uses of git include:
Gentoo repository (eclasses, licenses, profiles…),
</li>
<li>
- amending a commit created via <c>repoman commit</c> or <c>pkgdev commit</c>
- with additional files or fixups,
+ amending a commit created via <c>pkgdev commit</c> with additional files
+ or fixups,
</li>
<li>
- combining multiple commits created via <c>repoman commit</c> or
- <c>pkgdev commit</c> using <c>git rebase</c>.
+ combining multiple commits created via <c>pkgdev commit</c> using
+ <c>git rebase</c>.
</li>
</ul>
<p>
-Whenever <c>repoman</c> or <c>pkgdev</c> is not used to commit, you need to
-manually verify all packages affected by the commit using <c>repoman full</c> or
-<c>pkgcheck scan --commits</c>. When using <c>repoman</c>, it won't be aware of
-staged changes, so ensure that all files are included in the commit.
-Also, when using <c>git</c> manually, you must perform a manual sign-off to the
+Whenever <c>pkgdev</c> is not used to commit, you need to manually verify all
+packages affected by the commit using <c>pkgcheck scan --commits</c>. Also,
+when using <c>git</c> manually, you must perform a manual sign-off to the
<uri link="::general-concepts/copyright-policy/#Certificate of origin"/> using
the <c>-s </c> or <c>--signoff</c> option with your git commit commands. Make
sure you have read and understand the actual certificate.
@@ -224,8 +221,8 @@ appropriately:
<ul>
<li>
- <c>${CATEGORY}/${PN}:</c> Single Package (Note that <c>repoman commit</c>
- and <c>pkgdev commit</c> will automatically insert this for you)
+ <c>${CATEGORY}/${PN}:</c> Single Package (Note that <c>pkgdev commit</c>
+ will automatically insert this for you)
</li>
<li><c>${CATEGORY}:</c> Package Category</li>
<li><c>profiles:</c> Profile Directory</li>
@@ -286,15 +283,11 @@ are optionally used in Gentoo:
referenced, it will be closed (as fixed) automatically with reference
to the commit.
</li>
- <li>
- <c>Package-Manager:</c> This is automatically inserted by
- <c>repoman commit</c> and it specifies the version of
- <c>sys-apps/portage</c> on the system.
+ <li>
+ <c>Package-Manager:</c> Used by repoman to indicate Portage version
</li>
<li>
- <c>RepoMan-Options:</c> This is automatically inserted by
- <c>repoman commit</c> and records the options passed to repoman (such as
- --force) for the commit.
+ <c>RepoMan-Options:</c> Used by repoman to indicate repoman options
</li>
</ul>
diff --git a/ebuild-maintenance/new-ebuild/text.xml b/ebuild-maintenance/new-ebuild/text.xml
index eebdb8d..c6732de 100644
--- a/ebuild-maintenance/new-ebuild/text.xml
+++ b/ebuild-maintenance/new-ebuild/text.xml
@@ -54,10 +54,10 @@ examples.
</p>
<p>
-When committing to git, all developers should use <c>repoman commit</c> or
-<c>pkgdev commit</c> with <c>pkgdev push</c> instead of <c>git commit</c> to
-submit their ebuilds. Before committing, please run <c>repoman full</c> or
-<c>pkgcheck scan</c> to make sure you didn't forget something.
+When committing to git, all developers should use <c>pkgdev commit</c> with
+<c>pkgdev push</c> instead of <c>git commit</c> to submit their ebuilds.
+Before committing, please run <c>pkgcheck scan --commits</c> to make sure you
+didn't forget something.
</p>
</body>
diff --git a/ebuild-writing/common-mistakes/text.xml b/ebuild-writing/common-mistakes/text.xml
index 63c44d3..52bf790 100644
--- a/ebuild-writing/common-mistakes/text.xml
+++ b/ebuild-writing/common-mistakes/text.xml
@@ -457,8 +457,8 @@ the guidelines to use TABS rather than spaces. So <e>please</e> use tabs!
<body>
<p>
-Remember to run <c>repoman</c> or <c>pkgcheck</c> over your ebuilds so it can
-tell you if there is trailing whitespace at the end of lines or on empty lines.
+Remember to run <c>pkgcheck</c> over your ebuilds so it can tell you if there
+is trailing whitespace at the end of lines or on empty lines.
</p>
</body>
diff --git a/ebuild-writing/file-format/text.xml b/ebuild-writing/file-format/text.xml
index 0065b22..279d840 100644
--- a/ebuild-writing/file-format/text.xml
+++ b/ebuild-writing/file-format/text.xml
@@ -214,9 +214,9 @@ indenting, never inside strings.
</p>
<p>
-Avoid trailing whitespace: <c>repoman</c> or <c>pkgcheck</c> will warn you about
-this if your ebuild contains trailing or leading whitespace (whitespace instead
-of tabs for indentation) when you commit.
+Avoid trailing whitespace: <c>pkgcheck</c> will warn you about this if your
+ebuild contains trailing or leading whitespace (whitespace instead of tabs for
+indentation) when you commit.
</p>
<p>
diff --git a/ebuild-writing/misc-files/metadata/text.xml b/ebuild-writing/misc-files/metadata/text.xml
index 2bc6100..e24be93 100644
--- a/ebuild-writing/misc-files/metadata/text.xml
+++ b/ebuild-writing/misc-files/metadata/text.xml
@@ -372,7 +372,7 @@ using the <c>app-portage/metagen</c> tool.
</p>
<p>
-Commits of package metadata files are handled by <c>repoman</c> as
+Commits of package metadata files are handled by <c>pkgdev</c> as
part of regular package maintenance.
</p>
diff --git a/eclass-writing/text.xml b/eclass-writing/text.xml
index 2f316a3..41976c3 100644
--- a/eclass-writing/text.xml
+++ b/eclass-writing/text.xml
@@ -88,8 +88,7 @@ If there is an existing maintainer for an eclass (this is usually the case), you
</p>
<warning>
-Committing a broken eclass can kill huge numbers of packages. Since
-<c>repoman</c> is not eclass-aware, be very sure you do proper testing.
+Committing a broken eclass can kill huge numbers of packages.
</warning>
<p>
diff --git a/general-concepts/ebuild-revisions/text.xml b/general-concepts/ebuild-revisions/text.xml
index 755e0cf..4e78e80 100644
--- a/general-concepts/ebuild-revisions/text.xml
+++ b/general-concepts/ebuild-revisions/text.xml
@@ -52,9 +52,8 @@ of thumb could be used as a guideline:
etc.) and it would not be propagated using other means, then
the ebuild should be renamed to a new revision. If the package has
stable keywords, they should be moved to the new revision without
- dropping. To commit the ebuild, <c>repoman commit --straight-to-stable</c>
- option should be used. (Alternatively, <c>pkgdev commit</c> or <c>git
- commit</c> paired with <c>pkgcheck scan --commits</c>).
+ dropping. To commit the ebuild, <c>pkgdev commit</c> or <c>git
+ commit</c> paired with <c>pkgcheck scan --commits</c> should be used).
</li>
<li>
diff --git a/general-concepts/manifest/text.xml b/general-concepts/manifest/text.xml
index d4c97d8..4e77ae2 100644
--- a/general-concepts/manifest/text.xml
+++ b/general-concepts/manifest/text.xml
@@ -15,10 +15,9 @@ by the package. This is used to verify integrity upon fetching them.
</p>
<p>
-To generate the <c>Manifest</c>, use <c>ebuild foo.ebuild manifest</c>,
-<c>repoman manifest</c>, or <c>pkgdev manifest -m</c>. You may want to set
-<c>GENTOO_MIRRORS=</c> while calling it to fetch distfiles from their original
-locations immediately.
+To generate the <c>Manifest</c>, use <c>ebuild foo.ebuild manifest</c> or
+<c>pkgdev manifest -m</c>. You may want to set <c>GENTOO_MIRRORS=</c> while
+calling it to fetch distfiles from their original locations immediately.
</p>
</body>
diff --git a/keywording/text.xml b/keywording/text.xml
index baffaaa..30a7c73 100644
--- a/keywording/text.xml
+++ b/keywording/text.xml
@@ -195,10 +195,7 @@ a dependency of a package already keyworded.
</p>
<p>
-Do <b>not</b> commit straight to <c>arch</c> ("stable"). If it is necessary
-to do so, when using <c>repoman</c>, use
-<c>repoman commit --straight-to-stable</c> and <b>not</b> <c>--force</c> as
-this disables other QA checks.
+Do <b>not</b> commit straight to <c>arch</c> ("stable").
</p>
</body>
@@ -233,13 +230,6 @@ already available.
</p>
<p>
-If there are no new dependencies, do not remove keywords if your commit fails
-with <c>repoman</c> or <c>pkgdev</c> <d/> instead please commit with
-<c>repoman -I</c> and file a bug to the broken architecture, noting it in your
-git commit message.
-</p>
-
-<p>
Note that it is preferred to drop keywords on the package and request
rekeywording of it together with its new dependencies within the same bug to
allow the new code path(s) in your package to be tested. This won't happen if
diff --git a/tools-reference/text.xml b/tools-reference/text.xml
index 7cb316a..ae96a2a 100644
--- a/tools-reference/text.xml
+++ b/tools-reference/text.xml
@@ -35,9 +35,6 @@ when using these tools in ebuilds.
<include href="find/"/>
<include href="grep/"/>
<include href="head-and-tail/"/>
-<!--
-<include href="repoman/"/>
--->
<include href="sed/"/>
<include href="sort/"/>
<include href="tr/"/>