aboutsummaryrefslogtreecommitdiff
path: root/TODO
diff options
context:
space:
mode:
authorAnthony G. Basile <basile@opensource.dyc.edu>2011-04-13 17:25:55 -0400
committerAnthony G. Basile <basile@opensource.dyc.edu>2011-04-13 17:25:55 -0400
commit8aa93ea66bb4fac089d757c7eb68bc8d6cf3d696 (patch)
tree7a13f3d20db14264b4a68164d0c523a120b7fa67 /TODO
parentfix-gnustack.c: fixed open() to RDWR (diff)
downloadelfix-8aa93ea66bb4fac089d757c7eb68bc8d6cf3d696.tar.gz
elfix-8aa93ea66bb4fac089d757c7eb68bc8d6cf3d696.tar.bz2
elfix-8aa93ea66bb4fac089d757c7eb68bc8d6cf3d696.zip
fix-gnustack.c: added needed gelf_update_phdr()
Diffstat (limited to 'TODO')
-rw-r--r--TODO27
1 files changed, 27 insertions, 0 deletions
diff --git a/TODO b/TODO
new file mode 100644
index 0000000..3743b1d
--- /dev/null
+++ b/TODO
@@ -0,0 +1,27 @@
+
+1. Addec check for yasm to configure.ac
+
+2. Fix for 32-bit make check. This entails editing the yasm line in the chec and asm itself
+
+3. Fix the following print format errors that arrise on 32-bit:
+
+parse-elf.c:112: warning: format '%lu' expects type 'long unsigned int', but argument 6 has type 'Elf64_Addr'
+parse-elf.c:112: warning: format '%lu' expects type 'long unsigned int', but argument 7 has type 'Elf64_Off'
+parse-elf.c:112: warning: format '%lu' expects type 'long unsigned int', but argument 8 has type 'Elf64_Off'
+parse-elf.c:115: warning: format '%lu' expects type 'long unsigned int', but argument 2 has type 'size_t'
+parse-elf.c:164: warning: format '%lu' expects type 'long unsigned int', but argument 4 has type 'Elf64_Off'
+parse-elf.c:164: warning: format '%lu' expects type 'long unsigned int', but argument 5 has type 'Elf64_Addr'
+parse-elf.c:164: warning: format '%lu' expects type 'long unsigned int', but argument 6 has type 'Elf64_Addr'
+parse-elf.c:164: warning: format '%lu' expects type 'long unsigned int', but argument 7 has type 'Elf64_Xword'
+parse-elf.c:164: warning: format '%lu' expects type 'long unsigned int', but argument 8 has type 'Elf64_Xword'
+parse-elf.c:164: warning: format '%lu' expects type 'long unsigned int', but argument 9 has type 'Elf64_Xword'
+parse-elf.c:207: warning: format '%lu' expects type 'long unsigned int', but argument 4 has type 'Elf64_Xword'
+parse-elf.c:207: warning: format '%lu' expects type 'long unsigned int', but argument 5 has type 'Elf64_Addr'
+parse-elf.c:207: warning: format '%lu' expects type 'long unsigned int', but argument 6 has type 'Elf64_Off'
+parse-elf.c:207: warning: format '%lu' expects type 'long unsigned int', but argument 7 has type 'Elf64_Xword'
+parse-elf.c:207: warning: format '%lu' expects type 'long unsigned int', but argument 10 has type 'Elf64_Xword'
+parse-elf.c:207: warning: format '%lu' expects type 'long unsigned int', but argument 11 has type 'Elf64_Xword'
+parse-elf.c:220: warning: format '%lu' expects type 'long unsigned int', but argument 4 has type 'size_t'
+parse-elf.c:220: warning: format '%lu' expects type 'long unsigned int', but argument 5 has type 'loff_t'
+parse-elf.c:220: warning: format '%lu' expects type 'long unsigned int', but argument 6 has type 'size_t'
+