aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-10-05 07:18:23 +0300
committerAlfred Wingate <parona@protonmail.com>2023-10-05 07:18:23 +0300
commitfa74a98a2cb369584c8cab2feb329b91e9550fde (patch)
tree61a34edfa6f0e61d123cef946a33026741345b0c
parentsetup.py: Convert to setuptools (diff)
downloadelogv-fa74a98a2cb369584c8cab2feb329b91e9550fde.tar.gz
elogv-fa74a98a2cb369584c8cab2feb329b91e9550fde.tar.bz2
elogv-fa74a98a2cb369584c8cab2feb329b91e9550fde.zip
setup.py: Remove last distutils import
Signed-off-by: Alfred Wingate <parona@protonmail.com>
-rw-r--r--setup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 525126e..682254f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,3 @@
-from distutils.file_util import copy_file
-
from setuptools import setup
from setuptools import Command
from setuptools.command.build import build as _build
@@ -155,7 +153,7 @@ class install_messages(Command):
self.mkpath(out_dir)
out_file = os.path.join(out_dir,
'%s.mo' % self.distribution.get_name())
- copy_file(c, out_file)
+ self.copy_file(c, out_file)
## Class modified to add manpages command