aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-09-03 18:58:27 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-09-03 18:58:27 +0000
commit8386fcf7224b2ff1c056740ce8d2a5718c22c80c (patch)
tree711ce42244592bc8d25a15922855fb2ccb6779e3 /sys-auth
parent[temporary] reverse merging 661 (diff)
downloadembedded-cross-8386fcf7224b2ff1c056740ce8d2a5718c22c80c.tar.gz
embedded-cross-8386fcf7224b2ff1c056740ce8d2a5718c22c80c.tar.bz2
embedded-cross-8386fcf7224b2ff1c056740ce8d2a5718c22c80c.zip
Fix pam_ssh compilation for new stable version.
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_ssh/Manifest3
-rw-r--r--sys-auth/pam_ssh/files/pam_ssh-1.97-doublefree.patch20
-rw-r--r--sys-auth/pam_ssh/pam_ssh-1.97-r1.ebuild54
3 files changed, 77 insertions, 0 deletions
diff --git a/sys-auth/pam_ssh/Manifest b/sys-auth/pam_ssh/Manifest
index 240e301..fa799af 100644
--- a/sys-auth/pam_ssh/Manifest
+++ b/sys-auth/pam_ssh/Manifest
@@ -2,6 +2,9 @@ AUX pam_ssh-1.91-debian.patch 13855 RMD160 35cea4b64425351e94f8e5ec4689f17cb9733
AUX pam_ssh-1.91-openssl-0.9.8.patch 291 RMD160 f8cbc5831b4286f688f336ece32b7003a937cf4b SHA1 def422cb326165107ad9a4e347724284ae1abe30 SHA256 0e4b3bbd14b874bd9999f92cc2b4358f95e458654e0cc3bcc755790cbcdfea1d
AUX pam_ssh-1.91-syslog.patch 308 RMD160 f06a704155b76052bdd536e8b27a579cf9d0a4bb SHA1 2f80221a9a804e8da777179dc0768dbc73a7fb65 SHA256 b581d3422f93a8de7cd8b7dbc23c58da133eb63127059e6ff0b1f3e93e63a802
AUX pam_ssh-1.92-remove-rsa-tests.patch 1565 RMD160 fd65909d722d97a73a9beec72d464bf752996955 SHA1 3fce1158d670b6b8cf03ee5b2accb8b78a7d178f SHA256 c770057b3e909100c6ae70a476806018919b9de65e7b07ee34618f8f209e6821
+AUX pam_ssh-1.97-doublefree.patch 975 RMD160 45e10e818eea022e3990acaefd6f54aa2edf21f7 SHA1 193ccf9442506f2b98f07c794858c9aff85452df SHA256 035b20e4cfc0e723166c44414216ed4234d130877f9d717c905c5f1697421df0
AUX system-auth.example 612 RMD160 ffbcbc7535cd654c5a9e8ce2d3584b841aea6e53 SHA1 f90c19c81821789fe16a200320792887b8680c44 SHA256 3699db4595de56f31448c85a83c34277d1bebb5c805871b1c449446a49fb1989
DIST pam_ssh-1.92.tar.bz2 260444 RMD160 d7121ab89baaec82853758449f84429a387fee0e SHA1 33f537343fa4435717cbf83db52d19c6eed9a35e SHA256 d98f4698f692d46996b3845c2164528c8ad82f112df1c42abe7b8ebb2b133362
+DIST pam_ssh-1.97.tar.bz2 200184 RMD160 bc36f34fdf9ed545b8c52c7072e3f759a61527ce SHA1 ed5e529e94b754cb88dc64da4be397f046612fd0 SHA256 10233b0d3e480fdc977d4e3a1ea5a994cf1f257c3b948650a86e4d753796789d
EBUILD pam_ssh-1.92.ebuild 1460 RMD160 02a0e8e65af005670d864d1753426c0860b189c0 SHA1 4f3ab4f8d3d5c0817078055667e671bb5a80eb52 SHA256 d70ba7ee7e6e4769a9a4274c41e9e44db112cf8ab43af8861ca6e04df2f1e976
+EBUILD pam_ssh-1.97-r1.ebuild 1336 RMD160 9e5736531fe5345d56c111fdefe0367c0941eed9 SHA1 03b7dbdfe24d105196de3c6411c9d0d22984d683 SHA256 4cc0db6a49a20cc5d50dae280ee9b9558e34887f2b3dab15f204cff1f6e96352
diff --git a/sys-auth/pam_ssh/files/pam_ssh-1.97-doublefree.patch b/sys-auth/pam_ssh/files/pam_ssh-1.97-doublefree.patch
new file mode 100644
index 0000000..2f63ff8
--- /dev/null
+++ b/sys-auth/pam_ssh/files/pam_ssh-1.97-doublefree.patch
@@ -0,0 +1,20 @@
+--- pam_ssh-1.97/pam_ssh.c.orig 2009-08-01 20:11:00.000000000 +0200
++++ pam_ssh-1.97/pam_ssh.c 2009-08-01 20:11:16.000000000 +0200
+@@ -627,7 +627,7 @@
+ * than the file creation time */
+ if (retval = stat(per_agent, &stat_buf)) {
+ pam_ssh_log(LOG_ERR, "stat() failed on %s", per_agent);
+- free(per_agent);
++ pam_set_data(pamh, "ssh_agent_env_agent", NULL, NULL);
+ fclose(env_read);
+ return retval;
+ }
+@@ -646,7 +646,7 @@
+ if (start_agent) {
+ if ((env_write = open(per_agent, O_CREAT | O_WRONLY, S_IRUSR | S_IWUSR)) < 0) {
+ pam_ssh_log(LOG_ERR, "can't write to %s", per_agent);
+- free(per_agent);
++ pam_set_data(pamh, "ssh_agent_env_agent", NULL, NULL);
+ openpam_restore_cred(pamh);
+ return PAM_SERVICE_ERR;
+ }
diff --git a/sys-auth/pam_ssh/pam_ssh-1.97-r1.ebuild b/sys-auth/pam_ssh/pam_ssh-1.97-r1.ebuild
new file mode 100644
index 0000000..d70fd6a
--- /dev/null
+++ b/sys-auth/pam_ssh/pam_ssh-1.97-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/pam_ssh-1.97-r1.ebuild,v 1.6 2009/08/09 11:31:32 nixnut Exp $
+
+EAPI=2
+
+inherit pam autotools
+
+DESCRIPTION="Uses ssh-agent to provide single sign-on"
+HOMEPAGE="http://pam-ssh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.bz2"
+
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+# Doesn't work on OpenPAM.
+DEPEND="sys-libs/pam
+ sys-devel/libtool"
+
+RDEPEND="sys-libs/pam
+ virtual/ssh"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-doublefree.patch"
+
+ if tc-is-cross-compiler ; then
+ # Remove RSA tests, they useless because rsa support included in openssl
+ export ac_cv_openssldir="(system)"
+ epatch "${FILESDIR}/${PN}-1.92-remove-rsa-tests.patch"
+ fi
+
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ "--with-pam-dir=$(getpam_mod_dir)" \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+
+ find "${D}" -name '*.la' -delete || die "Unable to remove libtool archives."
+}
+
+pkg_postinst() {
+ elog "You can enable pam_ssh for system authentication by enabling"
+ elog "the ssh USE flag on sys-auth/pambase."
+}