summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2011-07-09 18:54:18 +0000
committerThomas Sachau <tommy@gentoo.org>2011-07-09 18:54:18 +0000
commit53a3add8497ec9bed50ea5a07a2566fdd6105f28 (patch)
tree94a7551aebb87c8e92ff802cfdde9dc48b9974fe /media-libs
parentRevert removal of core-evas-software-x11 configure option (diff)
downloadenlightenment-53a3add8497ec9bed50ea5a07a2566fdd6105f28.tar.gz
enlightenment-53a3add8497ec9bed50ea5a07a2566fdd6105f28.tar.bz2
enlightenment-53a3add8497ec9bed50ea5a07a2566fdd6105f28.zip
Revert removal of static modules
(Portage version: 2.2.0_alpha43-r1/svn/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/evas/ChangeLog6
-rw-r--r--media-libs/evas/evas-9999.ebuild39
2 files changed, 21 insertions, 24 deletions
diff --git a/media-libs/evas/ChangeLog b/media-libs/evas/ChangeLog
index 13ced33..0566178 100644
--- a/media-libs/evas/ChangeLog
+++ b/media-libs/evas/ChangeLog
@@ -1,11 +1,7 @@
# ChangeLog for media-libs/evas
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
- 09 Jul 2011; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> evas-9999.ebuild:
- Remove the static part, avoids compile failure for ecore with
- --enable-ecore-evas-software-x11, thanks to the_mgt for catching this issue
-
17 Dec 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
-evas-1.0.0_beta.ebuild:
Drop old
diff --git a/media-libs/evas/evas-9999.ebuild b/media-libs/evas/evas-9999.ebuild
index 340993f..f989e56 100644
--- a/media-libs/evas/evas-9999.ebuild
+++ b/media-libs/evas/evas-9999.ebuild
@@ -56,7 +56,8 @@ src_configure() {
use opengl && ewarn "opengl support is not implemented with xcb"
MY_ECONF="
--disable-gl-xlib
- --enable-software-xcb
+ --enable-software-xcb=static
+ --enable-xrender-xcb=static
"
else
MY_ECONF="
@@ -68,38 +69,38 @@ src_configure() {
MY_ECONF+="
$(use_enable altivec cpu-altivec)
$(use_enable bidi fribidi)
- $(use_enable bmp image-loader-bmp)
- $(use_enable bmp image-loader-wbmp)
+ $(use_enable bmp image-loader-bmp static)
+ $(use_enable bmp image-loader-wbmp static)
$(use_enable cache metric-cache)
$(use_enable cache word-cache)
- $(use_enable directfb)
+ $(use_enable directfb static)
$(use_enable doc)
- $(use_enable eet font-loader-eet)
- $(use_enable eet image-loader-eet)
- $(use_enable fbcon fb)
+ $(use_enable eet font-loader-eet static)
+ $(use_enable eet image-loader-eet static)
+ $(use_enable fbcon fb static)
$(use_enable fontconfig)
$(use_enable gles gl-flavor-gles)
$(use_enable gles gles-variety-sgx)
- $(use_enable gif image-loader-gif)
- $(use_enable ico image-loader-ico)
- $(use_enable jpeg image-loader-jpeg)
+ $(use_enable gif image-loader-gif static)
+ $(use_enable ico image-loader-ico static)
+ $(use_enable jpeg image-loader-jpeg static)
$(use_enable mmx cpu-mmx)
- $(use_enable png image-loader-png)
- $(use_enable ppm image-loader-pmaps)
- $(use_enable sdl software-sdl)
+ $(use_enable png image-loader-png static)
+ $(use_enable ppm image-loader-pmaps static)
+ $(use_enable sdl software-sdl static)
$(use_enable sse cpu-sse)
- $(use_enable svg image-loader-svg)
- $(use_enable tga image-loader-tga)
- $(use_enable tiff image-loader-tiff)
+ $(use_enable svg image-loader-svg static)
+ $(use_enable tga image-loader-tga static)
+ $(use_enable tiff image-loader-tiff static)
$(use_enable threads pthreads)
$(use_enable threads async-events)
$(use_enable threads async-preload)
$(use_enable threads async-render)
- $(use_enable X software-xlib)
- $(use_enable xpm image-loader-xpm)
+ $(use_enable X software-xlib static)
+ $(use_enable xpm image-loader-xpm static)
--enable-evas-magic-debug \
--enable-static-software-generic \
- --enable-buffer \
+ --enable-buffer=static \
--enable-cpu-c \
--enable-scale-sample \
--enable-scale-smooth \