summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-10-23 17:57:15 +0000
committerThomas Sachau <tommy@gentoo.org>2010-10-23 17:57:15 +0000
commitee710c27a846a24d8ea2ade60ac7c42159fc24ff (patch)
tree8f3b8f4bc9269fbbec062024f74d7adb2473ebd3 /x11-misc
parentDrop itask-ng, moved to e_modules-itask-ng (diff)
downloadenlightenment-ee710c27a846a24d8ea2ade60ac7c42159fc24ff.tar.gz
enlightenment-ee710c27a846a24d8ea2ade60ac7c42159fc24ff.tar.bz2
enlightenment-ee710c27a846a24d8ea2ade60ac7c42159fc24ff.zip
Switch to PYTHON_DEPEND, support multiple python ABIs, make static libs optional
(Portage version: 2.2_rc99-r1/svn/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/shellementary/shellementary-9999.ebuild36
1 files changed, 22 insertions, 14 deletions
diff --git a/x11-misc/shellementary/shellementary-9999.ebuild b/x11-misc/shellementary/shellementary-9999.ebuild
index 36e8989..4f224c0 100644
--- a/x11-misc/shellementary/shellementary-9999.ebuild
+++ b/x11-misc/shellementary/shellementary-9999.ebuild
@@ -1,29 +1,37 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-NEED_PYTHON="2.4"
+EAPI=2
+
+E_PYTHON=1
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+
ESVN_SUB_PROJECT="PROTO"
-inherit enlightenment python distutils
+
+inherit enlightenment
DESCRIPTION="Tool to display Elementary dialogs from the command line and shell scripts"
-RDEPEND=">=x11-libs/ecore-9999
- >=dev-python/python-evas-9999
- >=x11-libs/elementary-9999
- >=media-libs/edje-9999"
+IUSE="static-libs"
+
+RDEPEND=">=x11-libs/elementary-9999"
+DEPEND=${RDEPEND}
-src_unpack() {
- enlightenment_src_unpack
+src_prepare() {
+ enlightenment_src_prepare
+ python_copy_sources
}
-src_compile() {
- #distutils_src_compile
- ${python} setup.py build --prefix="${T}/usr"
+src_configure() {
+ python_execute_function -s enlightenment_src_configure
+}
+src_compile() {
+ python_execute_function -s enlightenment_src_compile
}
src_install() {
- #distutils_src_install
- ${python} setup.py install --prefix="${D}/usr"
+ python_execute_function -s enlightenment_src_install
}