summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-07-24 20:29:40 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-07-24 20:39:10 -0400
commitbfe8aea1761615f485cb8e51af7ff5ab33032550 (patch)
treed6eac46624fb8ac89a086c681285193ba631804c /configure.ac
parentRewrite the php-fpm init script to be more declarative. (diff)
downloadeselect-php-bfe8aea1761615f485cb8e51af7ff5ab33032550.tar.gz
eselect-php-bfe8aea1761615f485cb8e51af7ff5ab33032550.tar.bz2
eselect-php-bfe8aea1761615f485cb8e51af7ff5ab33032550.zip
Add a --with-piddir configure flag.
Our php-fpm init script defaulted to using /run for its pid file, but now that is configurable via the --with-piddir flag. Its value defaults to @LOCALSTATEDIR@ and the variable substitution should work whether or not --with-piddir is set explicitly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f8b4eb..ac55443 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,13 @@ AC_ARG_ENABLE(
esac],[apache2=false])
AM_CONDITIONAL([APACHE2], [test x$apache2 = xtrue])
+piddir=${piddir="@LOCALSTATEDIR@"}
+AC_ARG_WITH(piddir, AC_HELP_STRING([--with-piddir=DIR],
+ [where php-fpm PID files are placed [LOCALSTATEDIR]]),
+ if test x$withval != x -a x$withval != xno -a x$withval != xyes; then
+ piddir="$withval"
+ fi)
+AC_SUBST(piddir)
# List of output files.
AC_CONFIG_FILES([Makefile src/php.eselect.in doc/php-fpm.example.init.in])