aboutsummaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorDavid Cortarello <dcortarello@gmail.com>2015-03-25 01:48:36 -0300
committerAnthony G. Basile <blueness@gentoo.org>2015-03-27 11:34:13 -0400
commit6a398265f3bd30a252cba2b1ada04ff1c617cf96 (patch)
tree2a0761e4c4b46b8bb433e24032a4353cab3bed58 /test
parentconfigure.ac: update udev version to 219. (diff)
downloadeudev-6a398265f3bd30a252cba2b1ada04ff1c617cf96.tar.gz
eudev-6a398265f3bd30a252cba2b1ada04ff1c617cf96.tar.bz2
eudev-6a398265f3bd30a252cba2b1ada04ff1c617cf96.zip
Remove hardcoded path /run and configure using --with-rootrundir=
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.am1
-rw-r--r--test/test-udev.c2
2 files changed, 2 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 0920e5a9b..f6d68c24b 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -2,6 +2,7 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
AM_CPPFLAGS = \
-include $(top_builddir)/config.h \
+ -DUDEV_ROOT_RUN=\"$(rootrundir)\" \
-DVERSION=\"@VERSION@\" \
-I $(top_srcdir)/src/shared \
-I $(top_srcdir)/src/libudev \
diff --git a/test/test-udev.c b/test/test-udev.c
index 817f08fda..6bed8d61c 100644
--- a/test/test-udev.c
+++ b/test/test-udev.c
@@ -54,7 +54,7 @@ static int fake_filesystems(void) {
} fakefss[] = {
{ "test/sys", "/sys", "failed to mount test /sys" },
{ "test/dev", "/dev", "failed to mount test /dev" },
- { "test/run", "/run", "failed to mount test /run" },
+ { "test/run", UDEV_ROOT_RUN, "failed to mount test " UDEV_ROOT_RUN },
{ "test/run", "/etc/udev/rules.d", "failed to mount empty /etc/udev/rules.d" },
{ "test/run", "/lib/udev/rules.d", "failed to mount empty /lib/udev/rules.d" },
};