summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/app-text/tmispell/tmispell-9999.ebuild')
-rw-r--r--trunk/app-text/tmispell/tmispell-9999.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/trunk/app-text/tmispell/tmispell-9999.ebuild b/trunk/app-text/tmispell/tmispell-9999.ebuild
deleted file mode 100644
index b5a563e..0000000
--- a/trunk/app-text/tmispell/tmispell-9999.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-WANT_AUTOCONF="2.5"
-WANT_AUTOMAKE="1.9"
-AT_M4DIR="src/glibmm/m4"
-inherit eutils subversion autotools
-
-DESCRIPTION="Tmispell is interface between ispell OO.o Finnish spellcheckers.
-(This is a voikko patched version)"
-HOMEPAGE="http://www.hut.fi/~ptvirtan/programs/tmispell.html"
-ESVN_REPO_URI="https://svn.sourceforge.net/svnroot/voikko/trunk/tmispell"
-ESVN_PATCHES="tmispell-svn-autoconf-autopoint.patch"
-IUSE="enchant"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="-x86 -amd64" # Live SVN build not for general consumption
-
-DEPEND=">=app-text/ispell-3.2.06-r7
- !app-dicts/ispell-fi
- =app-text/voikko-9999
- >=dev-libs/glib-2.0.0
- nls? ( sys-devel/gettext )
- sys-apps/coreutils
- sys-apps/sed
- sys-devel/bison
- sys-apps/miscfiles
- >=sys-libs/ncurses-5.2"
-RDEPEND=">=app-text/ispell-3.2.06-r7
- =app-text/voikko-9999
- >=dev-libs/glib-2.0.0
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- subversion_src_unpack
- cd "${S}"
- # autogen.sh is b0rken, let’s just:
- find src -name '*.cc' -o -name '*.hh' | sort > po/POTFILES.in
- libtoolize --force
- eaclocal
- eautoheader
- eautomake
- eautoconf
- eautoheader
- autopoint
-}
-
-src_compile() {
- econf $(use_enable enchant ) || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS ChangeLog LUEMINUT NEWS README tmispell.conf.example
- if [[ -d "${ROOT}/usr/lib/ispell" ]] ; then
- dodir /usr/lib/ispell
- touch "${D}/usr/lib/ispell/suomi.hash" "${D}/usr/lib/ispell/suomi.aff"
- touch "${D}/usr/lib/ispell/finnish.hash" "${D}/usr/lib/ispell/finnish.aff"
- elif [[ -d "${ROOT}/usr/share/ispell" ]] ; then
- dodir /usr/share/ispell
- touch "${D}/usr/share/ispell/suomi.hash" "${D}/usr/share/ispell/suomi.aff"
- touch "${D}/usr/share/ispell/finnish.hash" "${D}/usr/share/ispell/suomi.aff"
- fi
- insinto /etc/
- newins "${FILESDIR}/tmispell.conf.gentoo" tmispell.conf
- sed -i "s:/usr/bin:${ROOT}/usr/bin:g" "${D}/etc/tmispell.conf"
- dosym /usr/bin/tmispell /usr/bin/ispell
-}