summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/app-text/voikko/voikko-1.6.ebuild')
-rw-r--r--trunk/app-text/voikko/voikko-1.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/trunk/app-text/voikko/voikko-1.6.ebuild b/trunk/app-text/voikko/voikko-1.6.ebuild
new file mode 100644
index 0000000..aeecd79
--- /dev/null
+++ b/trunk/app-text/voikko/voikko-1.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+MY_P=lib${P/_rc/rc}
+
+DESCRIPTION="Free Finnish spellchecking and hyphenation library"
+HOMEPAGE="http://www.lemi.fi/voikko/"
+#SRC_URI="http://www.puimula.org/htp/testing/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/voikko/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86" # release candidate
+IUSE=""
+
+DEPEND="sci-misc/malaga
+ || ( =sci-misc/suomi-malaga-1.0* =sci-misc/suomi-malaga-0.7*
+ =sci-misc/suomi-malaga-9999 )
+ virtual/libiconv"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P/rc?/}"
+
+src_compile() {
+ econf --with-dictionary-path="/usr/lib/suomi-malaga/" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README || die "docs missing"
+}